Win a copy of Think Java: How to Think Like a Computer Scientist this week in the Java in General forum!
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic

Composer: Command not found

 
Didier McGillis
Greenhorn
Posts: 27
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
A while back we had a contractor do a project and then get let go during the project and left a huge mess of uncompleted code, etc. The issue is that he partially implented the challenge question and answer for reg functionality, he was told that he should not be doing that etc and he "removed it", however not very well. So I am now trying to clean up this mess.

The gist of the message is "com.ibm.commerce.exception.ECSystemException: Messaging system. The composer encountered the following error: Command not found: "xxxUserRegistrationMessageView".." there are several errors as seen below where xxxUserRegistrationMessageView is mentioned as not being found and there is good reason since there is no command "xxxUserRegistrationMessageView". The issue is, and I have searched and search but cannot find any code, policy, or any entry in CMDVIEW using "xxxUserRegistrationMessageView" is there anywhere else I should be looking?
 
Didier McGillis
Greenhorn
Posts: 27
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Here is another stack trace.



I went on to production and looked at all of the struts-config-ext-xxx.xml files (they had bak in the ext) and I found one that had the forward. both local and test I cannot find this entry in any of the bak strut files.


 
Didier McGillis
Greenhorn
Posts: 27
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Maybe I should ask this in a different way. Where else should I be looking for this command that is missing.
I have checked Struts, DB, JSPs, Java and cannot find it to find out why the registration area thinks it should be looking for the command.
 
Mariana Yamanaka
Greenhorn
Posts: 2
 
Mariana Yamanaka
Greenhorn
Posts: 2
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Mariana Yamanaka wrote:Hey, take a look at this: http://pic.dhe.ibm.com/infocenter/wchelp/v6r0m0/index.jsp?topic=/com.ibm.commerce.esupport.doc/html/WebSphere_Commerce_Enterprise/swg21330941.html

Hope it helps anyone else who is looking for solving this problem.
 
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic