It's not a secret anymore!*
The moose likes BEA/Weblogic and the fly likes Aplication deployment using ant build.xml in to weblogic 8.1 server Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login
JavaRanch » Java Forums » Products » BEA/Weblogic
Bookmark "Aplication deployment using ant build.xml in to weblogic 8.1 server" Watch "Aplication deployment using ant build.xml in to weblogic 8.1 server" New topic
Author

Aplication deployment using ant build.xml in to weblogic 8.1 server

dahood shaikh
Greenhorn

Joined: Nov 27, 2012
Posts: 7
Hi guys,
I am new to ant and weblogic, I developed an enterprise application and want to deploy the app into server using ant build.xml file.
All the files are compiled successfully but while deploying the ear file into the server i get the below error

Error:
[echo] ********************************
[echo] myApplication.ear has successfully been built
[echo] ********************************
deploy:
[echo] deploying EAR: myApplication.ear
[echo] deploying to URL: ${wls.admin.url}
[echo] deploying to target server: ${wls.deploy.target}
[echo] User Name: ${wls.admin.user
}
[echo] Password: weblogic
[java] Unexpected Error Initializing Deployer: weblogic.management.deploy.utils.MBeanHomeToolException: Unable to connect to server ${wls.admin.url} as user ${wls.admin.user}.
[java] Reason: javax.naming.ConfigurationException [Root exception is java.net.MalformedURLException: no protocol: ${wls.admin.url}]
[java] at weblogic.jndi.internal.ExceptionTranslator.toNamingException(ExceptionTranslator.java:43)
[java] at weblogic.jndi.WLInitialContextFactoryDelegate.toNamingException(WLInitialContextFactoryDelegate.java:636)
[java] at weblogic.jndi.WLInitialContextFactoryDelegate.getInitialContext(WLInitialContextFactoryDelegate.java:306)
[java] at weblogic.jndi.Environment.getContext(Environment.java:166)
[java] at weblogic.jndi.Environment.getInitialContext(Environment.java:145)
[java] at weblogic.management.deploy.utils.MBeanHomeTool.getMBeanHome(MBeanHomeTool.java:170)
[java] at weblogic.Deployer.runBody(Deployer.java:721)
[java] at weblogic.utils.compiler.Tool.run(Tool.java:192)
[java] at weblogic.utils.compiler.Tool.run(Tool.java:147)
[java] at weblogic.Deployer.runMain(Deployer.java:574)
[java] at weblogic.Deployer.main(Deployer.java:557)
[java] Caused by: java.net.MalformedURLException: no protocol: ${wls.admin.url}
[java] at weblogic.rmi.spi.ServerURL.parseURL(ServerURL.java:353)
[java] at weblogic.rmi.spi.ServerURL.<init>(ServerURL.java:115)
[java] at weblogic.rjvm.ServerURL.<init>(ServerURL.java:45)
[java] at weblogic.jndi.WLInitialContextFactoryDelegate.getInitialContext(WLInitialContextFactoryDelegate.java:296)
[java] ... 8 more
[java] Check option -adminurl, -username and -password.

I am little surprised here, one thing that i noticed is on console i am not able to get the adminurl and the target as well as username
see the one mark red.

My probable guess is that its not able to read the adminurl,target and username.
Can anybody please tell me where i am going wrong?

Any help is highly appreciated.
Thanks

Carol Enderlin
drifter
Ranch Hand

Joined: Oct 10, 2000
Posts: 1364
Have you looked at where url, target, and user are defined? Why are they not being resolved?

 
 
subject: Aplication deployment using ant build.xml in to weblogic 8.1 server