wood burning stoves 2.0*
The moose likes Other Java Products and Servers and the fly likes Websphere CE  (Community edition) Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login

Win a copy of Murach's Java Servlets and JSP this week in the Servlets forum!
JavaRanch » Java Forums » Products » Other Java Products and Servers
Bookmark "Websphere CE  (Community edition)" Watch "Websphere CE  (Community edition)" New topic

Websphere CE (Community edition)

san metroca

Joined: Feb 21, 2013
Posts: 5
I hope this is correct place to put this problem...

my web app works good on tomcat server, now i am porting it to Websphere CE,

app reads properties file & load it to IntialContext, if I run the app using

- tomcat >> InitialContext ic has env variable and properties are loaded in env

but in

- Websphere CE >> InitialContext ic has env variable and env is empty

and app is failing?

just to add
in both cases (running on tomcat or websphere CE), InitialContext has variable myProp which has all properties from the file... which means properties file was read ..

I have properties file in classes dir and call a service from third party jar file, using debugger & decompiler I could found above difference, but now stuck here?

can you please share tips/suggestions in this case?

san metroca

Joined: Feb 21, 2013
Posts: 5
Able to replicate the issue in local with Websphere CE

In my local, I modified the code as following,

ADDEDing //2. in local file worked but I won't be able to add it in third party jar file?

Can you please suggest something?
san metroca

Joined: Feb 21, 2013
Posts: 5
Fixed this issue by adding jboss jars (used for NJDI) in endorsed directory of WAS-CE.

But now facing SocketTimeout while getting remote object.

How/where can we set sockettimeout property of WAS-CE ?
I agree. Here's the link: http://aspose.com/file-tools
subject: Websphere CE (Community edition)
Similar Threads
Resource injection for env entry in the field
EJB connect with Mysql
JDBC lookup failure through java:comp....
Initial Context
InitialContext and JNDI confusion