• Post Reply
  • Bookmark Topic Watch Topic
  • New Topic

Napkin Look and Feel: Unable to display button text when it is disabled

 
Yohan Weerasinghe
Ranch Hand
Posts: 507
Java Netbeans IDE Oracle
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Please have a look at the following code




This code is using Napkin look and feel. But as you can see, the button text is not displayed. That is because it is "disabled". If I "enable" the button, then the text will be displayed.

How can I fix this? Please help!
 
Tony Docherty
Bartender
Posts: 2939
59
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
This code is using Napkin look and feel. But as you can see, the button text is not displayed.

Unfortunately I don't have Napkin L&F and don;t want to download it so I can't see what you mean but from looking at the website for this look and feel the text should display as if it has been partly erased. If that is what you are seeing then that is how the L&F displays things and there isn't a lot you can do without changing the way the L&F works or you can use a different L&F.

If you are seeing something different can you include an image showing what it looks like.
 
Yohan Weerasinghe
Ranch Hand
Posts: 507
Java Netbeans IDE Oracle
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Tony Docherty wrote:
This code is using Napkin look and feel. But as you can see, the button text is not displayed.

Unfortunately I don't have Napkin L&F and don;t want to download it so I can't see what you mean but from looking at the website for this look and feel the text should display as if it has been partly erased. If that is what you are seeing then that is how the L&F displays things and there isn't a lot you can do without changing the way the L&F works or you can use a different L&F.

If you are seeing something different can you include an image showing what it looks like.


Thansks for the reply. This is how it is

Untitled.png
[Thumbnail for Untitled.png]
 
Tony Docherty
Bartender
Posts: 2939
59
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
The simple answer is I don't know. I've now download the L&F and it works on my system albeit when disabled the text is actually bold rather than rubbed out.
I suspect the L&F is buggy as the only download I could find had the prefix of alpha001
 
Yohan Weerasinghe
Ranch Hand
Posts: 507
Java Netbeans IDE Oracle
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Tony Docherty wrote:The simple answer is I don't know. I've now download the L&F and it works on my system albeit when disabled the text is actually bold rather than rubbed out.
I suspect the L&F is buggy as the only download I could find had the prefix of alpha001


OK Thanks . Anyone else know the answer?
 
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic