Granny's Programming Pearls
"inside of every large program is a small program struggling to get out"
JavaRanch.com/granny.jsp
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic

Same EAR deployed but a different result from 2 WAS servers under load balance

 
Hanumanth Korlakuna
Greenhorn
Posts: 1
  • 0
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Dear All,

I have an EAR built from RAD and is deployed the same single EAR in two testing WAS servers which are under load balance. But the strange fact is that i am getting it worked in one server with the expected result and the other server is giving an exception as below.

Actually i am invoking a webservice here, if i print the log i will have to get 2 as a constant value from Application.Properties, in one server log i am getting it as 2 but in other it says the below exception.

Java.lang.NumberFormatException: null

Is it due to EAR issue or some configuration settings in the server, i couldn't locate the exact issue. Please help me solve the issue with ideas...
 
Martin Vajsar
Sheriff
Pie
Posts: 3747
62
Chrome Netbeans IDE Oracle
  • 0
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Welcome to the Ranch, Hanumanth!

Can you post the full stack trace of your exception? And perhaps part of your code with the line the exception occurs on? The NumberFormatException is just too broad for anyoneto be able to infer anything about your problem (see also TellTheDetails ⇐ click).
 
With a little knowledge, a cast iron skillet is non-stick and lasts a lifetime.
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic