• Post Reply Bookmark Topic Watch Topic
  • New Topic
programming forums Java Mobile Certification Databases Caching Books Engineering Micro Controllers OS Languages Paradigms IDEs Build Tools Frameworks Application Servers Open Source This Site Careers Other all forums
this forum made possible by our volunteer staff, including ...
Marshals:
  • Campbell Ritchie
  • Ron McLeod
  • Paul Clapham
  • Bear Bibeault
  • Junilu Lacar
Sheriffs:
  • Jeanne Boyarsky
  • Tim Cooke
  • Henry Wong
Saloon Keepers:
  • Tim Moores
  • Stephan van Hulst
  • Tim Holloway
  • salvin francis
  • Frits Walraven
Bartenders:
  • Scott Selikoff
  • Piet Souris
  • Carey Brown

TextPad and file extensions

 
Sheriff
Posts: 6920
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
I know we have a few TextPad users here, so maybe someone can help me. Most of the time, I like TextPad - it's straightforward and it does the job. However, there's one thing that really irritates me; It just won't keep its hands off my file extensions!
A lot of the files I edit are of types known to TextPad (*.c, *.java. *.txt. *.html etc), and these work fine. But when I need to create a file of a different type, or even just with a different file extension, TextPad stubbornly adds '.txt'. SO I have to go in and change "ugh.cxx.txt" to "ugh.cxx", "adduser.tpl.txt" to "adduser.tpl", "report.xml.txt" to "report.xml", "showdetails.cgi.txt" to "showdetails.cgi" and so on.
So the question is: How do I tell TextPad to **** off and leave my filenames alone. I want it to save the file as the name I enter for it, not some other stupid name.
Any suggestions? I'll take suggestions for an equivalent editor which does this right, but I'd prefer a fix for TextPad if there is one ...
Many thanks in advance.
 
Ranch Hand
Posts: 193
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hi Frank
In the save dialog box, make sure "Save as type" is set to All files (*.*) and explicitly put your file extension on the file name.
I am using Textpad 4.4.0 and this works for me.
 
Bartender
Posts: 783
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Frank,
You can do as Graeme advised or remove your default extension to txt. It's under the menu Configure->Preferences...File. I put a blank under the "Default file extension" field.
I'm using TextPad v4.3.2. Let me know if this helps.
-Peter
 
Frank Carver
Sheriff
Posts: 6920
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
A big D'Oh! and slap-on forehead. Setting an empty "default file extension" did the trick.
Many thanks guys, that's a big decrease in my stress levels, and all thanks to the helpful folks at JavaRanch
 
I like tacos! And this tiny ad:
Building a Better World in your Backyard by Paul Wheaton and Shawn Klassen-Koop
https://coderanch.com/wiki/718759/books/Building-World-Backyard-Paul-Wheaton
    Bookmark Topic Watch Topic
  • New Topic