• Post Reply Bookmark Topic Watch Topic
  • New Topic
programming forums Java Mobile Certification Databases Caching Books Engineering Micro Controllers OS Languages Paradigms IDEs Build Tools Frameworks Application Servers Open Source This Site Careers Other Pie Elite all forums
this forum made possible by our volunteer staff, including ...
Marshals:
  • Campbell Ritchie
  • Tim Cooke
  • Ron McLeod
  • Jeanne Boyarsky
  • Paul Clapham
Sheriffs:
  • Liutauras Vilda
  • Henry Wong
  • Devaka Cooray
Saloon Keepers:
  • Tim Moores
  • Stephan van Hulst
  • Tim Holloway
  • Al Hobbs
  • Carey Brown
Bartenders:
  • Piet Souris
  • Mikalai Zaikin
  • Himai Minh

How to debug using Eclipse?

 
Ranch Hand
Posts: 104
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
Hi,
When I start the eclipse 2.0 with Java VM 1.4, I cannot debug my java code in this environment.
First I set the breakpoint, then I choose debug mode to run the project, it stopped but I can not use step into/over/return these functions, since they are unhighlighted.
The breakpoint window is also empty, "Unkown" method is shown there.
So Could U tell me waht is the problem when I start to debug ?
Thanks,
Roy
 
author
Posts: 14112
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
Mhh, works for me...
There are some known bugs in JDK 1.4.0, which are resolved in 1.4.1 regarding the debug API - but I think the symptoms you describe are pointing to another problem.
 
Roy Huang
Ranch Hand
Posts: 104
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
Hi,Ilja,
Thanks for Ur reply, I have tried with the JDK1.3.1 and start the eclipse without the VM setting, then I got my breakpoint in the breakpoint window, but the step into/over/return /resume/suspend/terminate these functions still can not be used.
Do I need to set anything else?
Thanks,
Roy
 
Ilja Preuss
author
Posts: 14112
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
Roy,
did you select your running application in the debug view?
 
Roy Huang
Ranch Hand
Posts: 104
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
Ilja,
Ja, I select the debug perspective only, but not the debug view, so it didn't work.
Now it works -- so great thanks!!
Have a nice weekend,
Roy
 
Ilja Preuss
author
Posts: 14112
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
You're welcome!
reply
    Bookmark Topic Watch Topic
  • New Topic