Win a copy of Kotlin in Action this week in the Kotlin forum!
  • Post Reply Bookmark Topic Watch Topic
  • New Topic

Problem running .bat script within ant in Eclipse  RSS feed

Eric Fletcher
Ranch Hand
Posts: 188
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Greetings all,
I'm having an ant-related issue in Eclipse. As part of our build process, we run a .bat file that does some setup via the ant exec task. When I run the build from the command line, no problem, the batch file executes without fail. But when I run the build as an external builder in Eclipse, I get an IOException on the exec task and the build fails with the message "debug error = 2".
I did a quick google search and found a few similar issues but nothing matching this problem exactly. The consensus I found was that "error = 2" meant that the executable in question needs to be in my PATH, but I'm dubious that is my problem since the build runs fine from the command line.
Has anyone seen this behavior from ant/Eclipse before, and might have a resolution? I'm running Eclipse 2.1 and ant 1.5.
Thanks in advance,
[ February 19, 2004: Message edited by: Eric Fletcher ]
It is sorta covered in the JavaRanch Style Guide.
  • Post Reply Bookmark Topic Watch Topic
  • New Topic
Boost this thread!