Win a copy of The Little Book of Impediments (e-book only) this week in the Agile and Other Processes forum!
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic

WSAD 5.1.x --> JDK 1.5???

 
Thomas Mcfarrow
Ranch Hand
Posts: 137
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hello,

I tried to upgrade JDK 1.4 to 1.5 in WSAD 5.1.2 but it didn't work.

I could change the JRE to 1.5: Window -> Preferences ->Java ->installed JREs.

The problem is that I can't change the compiler to 1.5 from 1.4 to support the new constructs (generics, autoboxing, etc) and compile!!!

How do I upgrade the complier to 1.5 in WSAD 5.1.2?

Thanks in advance!
 
Paul Sturrock
Bartender
Posts: 10336
Eclipse IDE Hibernate Java
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
You can't. WSAD is very restrictive when it comes to the JDK versions it supports. This seems to be because it doesn't want to allow you to write code in a JDK newer than WebSphere itself supports (for example, WSAD 5.0 doesn't support anything higher than 1.3.1). Very, very annoying I know.

You might just want to use normal Eclipse, rather then the WSAD-flavoured version.
 
Thomas Mcfarrow
Ranch Hand
Posts: 137
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Thanks for the reply,

It is very very annoying... does anyone know a hack?

I guess I could download and install eclipse .
 
Bharat Ruparel
Ranch Hand
Posts: 493
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Your solution can be as simple as upgrading to RAD6 from WSAD 5.1.2. RAD6 is based on Eclipse 3.x technology and therefore natively uses 1.4.x JRE.
Bharat
 
Jeanne Boyarsky
author & internet detective
Marshal
Posts: 35279
384
Eclipse IDE Java VI Editor
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
RAD 6 currently uses 1.4. The version of Eclipse using 1.5 is still in beta, so no versions of WSAD have support yet.
 
Ilja Preuss
author
Sheriff
Posts: 14112
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Originally posted by Paul Sturrock:
You can't. WSAD is very restrictive when it comes to the JDK versions it supports. This seems to be because it doesn't want to allow you to write code in a JDK newer than WebSphere itself supports (for example, WSAD 5.0 doesn't support anything higher than 1.3.1). Very, very annoying I know.


A more legitimate reason might be that to support a newer JDK, the Eclipse compiler needs to be adapted, and that work was just finished in the 3.1 stream.
 
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic