Win a copy of Svelte and Sapper in Action this week in the JavaScript forum!
  • Post Reply Bookmark Topic Watch Topic
  • New Topic
programming forums Java Mobile Certification Databases Caching Books Engineering Micro Controllers OS Languages Paradigms IDEs Build Tools Frameworks Application Servers Open Source This Site Careers Other all forums
this forum made possible by our volunteer staff, including ...
Marshals:
  • Campbell Ritchie
  • Ron McLeod
  • Paul Clapham
  • Bear Bibeault
  • Junilu Lacar
Sheriffs:
  • Jeanne Boyarsky
  • Tim Cooke
  • Henry Wong
Saloon Keepers:
  • Tim Moores
  • Stephan van Hulst
  • Tim Holloway
  • salvin francis
  • Frits Walraven
Bartenders:
  • Scott Selikoff
  • Piet Souris
  • Carey Brown

trouble with geronimo plugin for eclipse

 
Ranch Hand
Posts: 18944
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
i'd like to create a new j2ee server profile in eclipse and so was following the instructions given here. all the players seem to be in place: eclipse 3.1 with latest wtp and geronimo M4.

clicking on File - New - Other - Server all jives with the instructions, but instead of the expected behavior when clicking Next on the new server wizard:


You�ll next be prompted for the installed location of the Apache server and the root directory used to locate the jars necessary for the development project�s classpath. The next page allows you to define additional information about the server; of particular importance is the administration user ID and password that you specified when you installed Geronimo. On the final page of the wizard, you can add existing projects to the server. Because you have not yet created any projects, just select Finish.



...nothing happens. i click Next again, the wizard title changes to "Add and Remove Projects", but the view pane does not update to anything that jives with the description given. seems like UI support in the plugin is broken for my setup. "Finish" is never enable: Here's a screenshot

eclipse log has something to say about this, but i don't understand the issue yet:



the "Server runtime" dropdown near the bottom of the new server wizard has three odd-looking entries:
  • Apache Geronimo v1.0 (Generic)
  • Apache Geronimo v1.0 (Generic) 2
  • Apache Geronimo v1.0 (Generic) 3


  • not sure if this is significant or has any bearing on the issue i'm having.

    [ August 15, 2005: Message edited by: Erick Reid ]
     
    Ranch Hand
    Posts: 346
    • Mark post as helpful
    • send pies
    • Quote
    • Report post to moderator
    Can you email this to the IBM article author??..

    Its strange..

    I am not having a problem defining server profiles as of yet..
     
    Anonymous
    Ranch Hand
    Posts: 18944
    • Mark post as helpful
    • send pies
    • Quote
    • Report post to moderator
    fred,

    thanks for reply. i did not see contact info for the author. will take another look later today. have not had any time to mess with this issue today. it is bugging me though.
     
    author & internet detective
    Posts: 40200
    816
    Eclipse IDE VI Editor Java
    • Mark post as helpful
    • send pies
    • Quote
    • Report post to moderator
    Tim Francis: francis@ca.ibm.com

    It's at the top of the IBM article.
     
    Anonymous
    Ranch Hand
    Posts: 18944
    • Mark post as helpful
    • send pies
    • Quote
    • Report post to moderator
    thanks, jeanne. my "missing it" speaks right to the hurried couple of days i've had -- got a chance to scroll to the bottom, look at tim's picture, see no e-mail, and get right back to bug fixes in other code.
     
    Anonymous
    Ranch Hand
    Posts: 18944
    • Mark post as helpful
    • send pies
    • Quote
    • Report post to moderator
    sent note to tim. thanks again!

    also uploaded fuller clip of eclipse log file detailing the error that is logged when i click next in the new server wizard, having selected Apache - Geronimo v1.0 Server.
     
    Anonymous
    Ranch Hand
    Posts: 18944
    • Mark post as helpful
    • send pies
    • Quote
    • Report post to moderator
    tim replied, indicating that they need to investigate how the geronimo plugin interacts with the latest wtp release. he's opened an issue in their bugzilla.

    thanks everyone!
     
    Anonymous
    Ranch Hand
    Posts: 18944
    • Mark post as helpful
    • send pies
    • Quote
    • Report post to moderator
    grrr. i made a clean install of eclipse 3.1, wtp 0.7 and the geronimo plugin and still had troubles. worse, i downloaded the latest jboss ide plugin (1.4.1) and followed the steps in this article and had problems with that plugin too. there may well be something wrong with my setup, but i'm wondering if some incompatabilities were introduced with the latest eclipse and webtools.
    [ August 19, 2005: Message edited by: Erick Reid ]
     
    ranger
    Posts: 17346
    11
    Mac IntelliJ IDE Spring
    • Mark post as helpful
    • send pies
    • Quote
    • Report post to moderator
    What does it keep wanting to jump out of a plane and yell its own name?

    Sorry for the hijack, we now return to your regularly scheduled thread.

    Mark
     
    Anonymous
    Ranch Hand
    Posts: 18944
    • Mark post as helpful
    • send pies
    • Quote
    • Report post to moderator
    huh?

    i'm presently doing another (one-handed*) install of eclipse having realized my missing a very important direction: use wtp 1.0 M4, not (stable) 0.7. d'oh. will let thread know how it goes. hopes are high.

    *baby nathaniel is in other arm, staring intently at saloon's moosehead logo
     
    Anonymous
    Ranch Hand
    Posts: 18944
    • Mark post as helpful
    • send pies
    • Quote
    • Report post to moderator

    What does it keep wanting to jump out of a plane and yell its own name?



    oh, "geronimooooo!" sadly, i had to google it in order to be
    reminded. :roll:

    my eclipse 3.1, wtp 1.0 m4, geronimo plugin attempt with same result. still plugging away: will try again w/ pre 3.1 version on eclipse.

    myeclipse was broken by 3.1, and so too it seems for the geronimo and jboss plugins.
     
    Won't you be my neighbor? - Fred Rogers. tiny ad:
    the value of filler advertising in 2020
    https://coderanch.com/t/730886/filler-advertising
      Bookmark Topic Watch Topic
    • New Topic