Win a flower (🌹) or copy of Real-World Software Development: A Project-Driven Guide to Fundamentals in Java (📚) this week in the Agile and Other Processes forum!
  • Post Reply Bookmark Topic Watch Topic
  • New Topic
programming forums Java Mobile Certification Databases Caching Books Engineering Micro Controllers OS Languages Paradigms IDEs Build Tools Frameworks Application Servers Open Source This Site Careers Other all forums
this forum made possible by our volunteer staff, including ...
Marshals:
  • Campbell Ritchie
  • Paul Clapham
  • Liutauras Vilda
  • Knute Snortum
  • Bear Bibeault
master stewards:
  • Devaka Cooray
  • Jeanne Boyarsky
  • Junilu Lacar
garden masters:
  • Ron McLeod
  • Stephan van Hulst
  • Tim Moores
  • Carey Brown
  • salvin francis
gardeners:
  • Tim Holloway
  • Piet Souris
  • Frits Walraven

Specify port number in CVS Repository doesnt work

 
pioneer
Posts: 167
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
For me, setting up the tunnel through CVS client (linux), doesnt seem to be working.

I read about that the port number could be passed on command line, or set a variable CVS_CLIENT_PORT.
http://www.cvsnt.org/manual/html/Remote-repositories.html

I have CVS running on port 2401. It works fine though command line, without specifying the port number.
But when I pass the port number on command line like below, it gives an error.

/home/tomcat > cvs -d :p server:user :p asswd@xxxx21:2401:/export/home/cvs login
cvs login: CVSROOT may only specify a positive, non-zero, integer port (not `2601:').
cvs login: Perhaps you entered a relative pathname?
cvs [login aborted]: Bad CVSROOT: ` :p server :p atel:welcome@mltsrv21:2601:/export/home/cvs'.

Actually I have another CVS to connect to, which is running on a different port.

Help would be appreciated.

Regards
Aruneesh

[edited to disable smilies - Jim]
[ January 05, 2006: Message edited by: Jim Yingst ]
 
master steward
Posts: 9099
12
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator

Originally posted by Aruneesh Salhotra:
I have CVS running on port 2401. It works fine though command line, without specifying the port number. But when I pass the port number on command line like below, it gives an error.

/home/tomcat > cvs -d:pserver:user:passwd@xxxx21:2401:/export/home/cvs login
cvs login: CVSROOT may only specify a positive, non-zero, integer port (not `2601:').
cvs login: Perhaps you entered a relative pathname?
cvs [login aborted]: Bad CVSROOT: `:pserver:user:passwd@xxxx21:2601:/export/home/cvs'.



I notice that your error message claims you entered 2601 rather than 2401.
[ January 09, 2006: Message edited by: Marilyn de Queiroz ]
 
Aruneesh Salhotra
pioneer
Posts: 167
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
That was probably the typo. I fugured out the issue.
Instead of
cvs -d server:user asswd@xxxx21:2601:/export/home/cvs login

it should be (see there is no colon after the port number.
cvs -d server:user asswd@xxxx21:2601/export/home/cvs login
 
I like tacos! And this tiny ad:
Java file APIs (DOC, XLS, PDF, and many more)
https://products.aspose.com/total/java
  • Post Reply Bookmark Topic Watch Topic
  • New Topic
Boost this thread!