Win a copy of The Java Performance Companion this week in the Performance forum!
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic

Eclipse: "Unable to read workbench state , workbench UI layout will be reset."

 
Vinayak patil
Ranch Hand
Posts: 67
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hi Ranchers,

Whenever I close eclipse and try to open it again I get the following message:

"Unable to read workbench state, workbench UI layout will be reset." After I click OK I lose all the workspace information and so I have to configure everything again including creating the projects I am working on.


I tried creating new workspace but that did not help.I then installed a new version of eclipse, that did not help either and I keep getting the same error.

Please let me know how to overcome this.

Thanks in advance,
Vinayak
 
Vinayak patil
Ranch Hand
Posts: 67
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hi Checked the .log file in .metadata folder. This is the exception that is logged:

 
Mr. C Lamont Gilbert
Ranch Hand
Posts: 1170
Eclipse IDE Hibernate Ubuntu
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
looks like you have an old workspace and also that you can not write to it so eclipse keeps trying to open the same workspace. Make sure you can write to your workspace.
 
Vinayak patil
Ranch Hand
Posts: 67
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
I checked the workspace folder and changed the permissions so I am able to write to it. It is still not working.
 
Mr. C Lamont Gilbert
Ranch Hand
Posts: 1170
Eclipse IDE Hibernate Ubuntu
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Heh, yea. If you can write to the log I suppose you can write to the workspace...

Try "eclipse.exe - clean" or your Linux equivalent.
 
Rahul Mootha
Greenhorn
Posts: 1
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Try this .. it worked for me when i had problem in loading my workbench:
Go to your workspace folder

Make a backup of your “.metadata“-folder (very important!!)
navigate into the “.plugins“-folder located inside “.metadata“
delete the folder “org.eclipse.ui.workbench“
startup eclipse again and check if there is still everything you need
 
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic