• Post Reply Bookmark Topic Watch Topic
  • New Topic
programming forums Java Mobile Certification Databases Caching Books Engineering Micro Controllers OS Languages Paradigms IDEs Build Tools Frameworks Application Servers Open Source This Site Careers Other Pie Elite all forums
this forum made possible by our volunteer staff, including ...
Marshals:
  • Campbell Ritchie
  • Ron McLeod
  • Paul Clapham
  • Rob Spoor
  • Liutauras Vilda
Sheriffs:
  • Jeanne Boyarsky
  • Junilu Lacar
  • Tim Cooke
Saloon Keepers:
  • Tim Holloway
  • Piet Souris
  • Stephan van Hulst
  • Tim Moores
  • Carey Brown
Bartenders:
  • Frits Walraven
  • Himai Minh

configuring Tomcat 5.0 with eclipse

 
Greenhorn
Posts: 9
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
When I execute some JSP programs i got the error as .jsp program
cannot access java.lang.Object
bad class file: C:\Program Files\Java\jre1.5.0_10\lib\rt.jar(java/lang/Object.class)
class file has wrong version 49.0, should be 48.0
Please remove or make sure it appears in the correct subdirectory of the classpath.
public final class JD_jsp extends org.apache.jasper.runtime.HttpJspBase
^
1 error

Can anybody tell me how to resolve this error
 
Sheriff
Posts: 67583
173
Mac Mac OS X IntelliJ IDE jQuery TypeScript Java iOS
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
"msg msg",

There aren't many rules that you need to worry about here on the Ranch, but one that we take very seriously regards the use of proper names. Please take a look at the JavaRanch Naming Policy and adjust your display name to match it.

In particular, your display name must be a first and a last name separated by a space character, and must not be obviously fictitious.

Thanks!
bear
JavaRanch Sheriff
 
Ranch Hand
Posts: 189
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
I have also seen this error at build time. As I recall, it has to do with the compliance level of your selected compiler. Try this: go to "Project" -> "Properties" -> "Java Compiler" and check the compiler compliance level that is selected under JDK compliance. This should be set to "1.4" for Tomcat 5.5.x, and I think that's also true for Tomcat 5.0.x.

I also recall seeing an option to enable/disable pre-compiled JSP's at build time, and that also seems to be related to this kind of error, but I cannot find that option anywhere in my Eclipse 3.2 configuration. If you find this, try disabling it.

Good luck!
[ February 07, 2007: Message edited by: Philip Shanks ]
 
author & internet detective
Posts: 40721
827
Eclipse IDE VI Editor Java
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
"Mona G.",
That's a step in the right direction. Please note that we do require a last name though, not just a last initial.

Thanks,
Jeanne
Forum Bartender
 
Paddy spent all of his days in the O'Furniture back yard with this tiny ad:
the value of filler advertising in 2021
https://coderanch.com/t/730886/filler-advertising
reply
    Bookmark Topic Watch Topic
  • New Topic