• Post Reply Bookmark Topic Watch Topic
  • New Topic

The WebLogic Server did not start up properly.java.io.Invalid Class Exception...?

 
Mallik Avula
Ranch Hand
Posts: 86
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hi friends i am using MyEclipse 5, eclipse3.2 and Weblogic 8.1
when i start the weblogic normally it is running fine, but if i start it from MyEclipse it is giving the following error .

The WebLogic Server did not start up properly.
java.io.InvalidClassException: javax.management.MBeanAttributeInfo; local class incompatible: stream classdesc serialVersionUID = 7043855487133450673, local class serialVersionUID = 8644704819898565848
at java.io.ObjectStreamClass.initNonProxy(ObjectStreamClass.java:546)
at java.io.ObjectInputStream.readNonProxyDesc(ObjectInputStream.java:1551)
at java.io.ObjectInputStream.readClassDesc(ObjectInputStream.java:1465)
at java.io.ObjectInputStream.readNonProxyDesc(ObjectInputStream.java:1551)
at java.io.ObjectInputStream.readClassDesc(ObjectInputStream.java:1465)
at java.io.ObjectInputStream.readOrdinaryObject(ObjectInputStream.java:1698)
at java.io.ObjectInputStream.readObject0(ObjectInputStream.java:1304)
at java.io.ObjectInputStream.readArray(ObjectInputStream.java:1633)
at java.io.ObjectInputStream.readObject0(ObjectInputStream.java:1298)
at java.io.ObjectInputStream.defaultReadFields(ObjectInputStream.java:1917)
at java.io.ObjectInputStream.readSerialData(ObjectInputStream.java:1841)
at java.io.ObjectInputStream.readOrdinaryObject(ObjectInputStream.java:1718)
at java.io.ObjectInputStream.readObject0(ObjectInputStream.java:1304)
at java.io.ObjectInputStream.readObject(ObjectInputStream.java:349)
at weblogic.management.internal.TypesHelper.getMBeanInfo(TypesHelper.java:261)
at weblogic.management.internal.TypesHelper.getAdminOrConfigMBeanInfo(TypesHelper.java:366)
at weblogic.management.internal.ConfigurationMBeanImpl.<init>(ConfigurationMBeanImpl.java:128)
at weblogic.management.AdminServer.<init>(AdminServer.java:59)
at weblogic.management.AdminServerAdmin.initialize(AdminServerAdmin.java:245)
at weblogic.t3.srvr.T3Srvr.initializeHere(T3Srvr.java:753)
at weblogic.t3.srvr.T3Srvr.initialize(T3Srvr.java:664)
at weblogic.t3.srvr.T3Srvr.run(T3Srvr.java:342)
at weblogic.Server.main(Server.java:32)
--------------- nested within: ------------------
weblogic.management.configuration.ConfigurationException: - with nested exception:

why this is? how to solve this?
plase waiting for replies?

Regards
Mallik Avula
 
Nathan Pruett
Bartender
Posts: 4121
IntelliJ IDE Java Spring
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
The first thing to check is to make sure that Eclipse and Weblogic are running in the same JVM version. (i.e. both 1.4 or 1.5, etc.)
 
What are you doing? You are supposed to be reading this tiny ad!
the new thread boost feature brings a LOT of attention to your favorite threads
https://coderanch.com/t/674455/Thread-Boost-feature
  • Post Reply Bookmark Topic Watch Topic
  • New Topic
Boost this thread!