Win a copy of The Little Book of Impediments (e-book only) this week in the Agile and Other Processes forum!
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic

WSAD operability with J2SDK 1.4

 
Avinash Tiwari
Ranch Hand
Posts: 50
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Does WSAD 5.X work with J2SDK 1.4. If yes what would be the changes that would be required for project to run on 1.4 in WSAD 5.X...
 
Jay Damon
Ranch Hand
Posts: 282
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
I'm almost certain it does. I don't have access to a WSAD 5 installation to check right now but I am using RAD 6.0 with JDK 1.4. After installing the actual JDK, options you may need to set in eclipse/WSAD/RAD include:

1) Installed JREs
2) Java Compiler Compliance Level
3) J2EE Version (if using J2EE)

Note that you may also set Java Compiler properties for individual projects but I have never had any reason to do so.
 
Jeanne Boyarsky
author & internet detective
Marshal
Posts: 35279
384
Eclipse IDE Java VI Editor
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Avinash,
Sort of. You can change the compiler by doing what Jay described.

However, you cannot change the server JRE. So if you are developing a J2EE you need to upgrade to RAD 6 in order to use Java 1.4.
 
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic