Win a copy of The Java Performance Companion this week in the Performance forum!
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic

iRAD 7 - WAS 6.1 - jdk 1.4.2 compatibility

 
Abi Krish
Greenhorn
Posts: 2
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Does this combination work ?

I setup my application in IRAD7 and WAS6.1 using the default JDK5 installed along with iRad. Everything worked fine with this combination.

But my project needs to be tested with jdk1.4 :-(

So I changed the
preferences
under "Installed JREs" to use my other JDK1.4 version and also under Java--> Compiler --> set the "Jdk compliance level" to 1.4

After doing this I got the error "
Java compiler level does not match the version of the installed java project facet
"

Is there any more settings that can be done or will this combination not work at all?
Should WAS6.1 server be configured with this runtime jre ? If so, how ?

Thanks for any help !
 
Jeanne Boyarsky
author & internet detective
Marshal
Posts: 34686
367
Eclipse IDE Java VI Editor
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Abi,
What you did is correct for the compiler. As for the server, you can't change the JRE it uses. What you can do is use the WAS 5 compatibility server when you deploy within RAD.
 
Abi Krish
Greenhorn
Posts: 2
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Thanks, but I got a solution!

This error was occuring because, when I created the project I used the default project facet setting with Jdk5 and WAS 6.1...

I changed this setting by going into Project properties --> Project facets to jdk 1.4 and WAS 6.0.

Now the application is up and running in this combination.
 
Piyush Garg
Greenhorn
Posts: 2
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Thanks for the solution that indeed solved the problem
 
Jegadeesh Chandrabose
Greenhorn
Posts: 1
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Thanks for your valueable comments to resolve this issue
 
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic