• Post Reply Bookmark Topic Watch Topic
  • New Topic
programming forums Java Mobile Certification Databases Caching Books Engineering Micro Controllers OS Languages Paradigms IDEs Build Tools Frameworks Application Servers Open Source This Site Careers Other all forums
this forum made possible by our volunteer staff, including ...
Marshals:
  • Campbell Ritchie
  • Jeanne Boyarsky
  • Bear Bibeault
  • Knute Snortum
  • Liutauras Vilda
Sheriffs:
  • Tim Cooke
  • Devaka Cooray
  • Paul Clapham
Saloon Keepers:
  • Tim Moores
  • Frits Walraven
  • Ron McLeod
  • Ganesh Patekar
  • salvin francis
Bartenders:
  • Tim Holloway
  • Carey Brown
  • Stephan van Hulst

error : Cannot use classic compiler, as it is not available  RSS feed

 
Ranch Hand
Posts: 616
1
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
I am trying to build poolman a tool that u can use with tomacat it pools databse connections>

When I try to build the application I get the following error message:


C:\poolman-2.0.3\build>build
Buildfile: build.xml

init:

prepare:

compile:
[javac] Compiling 48 source files to C:\poolman-2.0.3\bin
[javac] Modern compiler is not available - using classic compiler

BUILD FAILED

C:\poolman-2.0.3\build\build.xml:49: Cannot use classic compiler, as it is not available A common solution is to set the environment variable JAVA_HOME to your
jdk directory.

Total time: 1 second
C:\poolman-2.0.3\build>

when I do this:

C:\poolman-2.0.3\build>echo %JAVA_HOME%
C:\jdk1.3

C:\poolman-2.0.3\build>

Why is ant throwing up this message.

Thanks for any help Tony
 
Ranch Hand
Posts: 451
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Poolman may be expecting the jsdk 1.4.
 
Ranch Hand
Posts: 101
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
I'm not sure why it's failing, but there are several links on google about it.

For Ant, modern compiler is anything 1.3 and above, so it should work. Classic is 1.1 and 1.2.
 
Don Stadler
Ranch Hand
Posts: 451
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator

Originally posted by Tony Evans:


C:\poolman-2.0.3\build\build.xml:49: Cannot use classic compiler, as it is not available A common solution is to set the environment variable JAVA_HOME to your
jdk directory.

C:\poolman-2.0.3\build>echo %JAVA_HOME%
C:\jdk1.3

Why is ant throwing up this message.



Tony, I would check to make certain that %JAVA_HOME%/bin/javac exists and that the PATH environmental variable is set in your context and includes %JAVA_HOME%/bin .
 
I miss the old days when I would think up a sinister scheme for world domination and you would show a little emotional support. So just look at this tiny ad:
RavenDB is an Open Source NoSQL Database that’s fully transactional (ACID) across your database
https://coderanch.com/t/704633/RavenDB-Open-Source-NoSQL-Database
  • Post Reply Bookmark Topic Watch Topic
  • New Topic
Boost this thread!