• Post Reply Bookmark Topic Watch Topic
  • New Topic
programming forums Java Mobile Certification Databases Caching Books Engineering Micro Controllers OS Languages Paradigms IDEs Build Tools Frameworks Application Servers Open Source This Site Careers Other Pie Elite all forums
this forum made possible by our volunteer staff, including ...
Marshals:
  • Campbell Ritchie
  • Jeanne Boyarsky
  • Ron McLeod
  • Paul Clapham
  • Liutauras Vilda
Sheriffs:
  • paul wheaton
  • Rob Spoor
  • Devaka Cooray
Saloon Keepers:
  • Stephan van Hulst
  • Tim Holloway
  • Carey Brown
  • Frits Walraven
  • Tim Moores
Bartenders:
  • Mikalai Zaikin

Eclipse and Ant Problem

 
Ranch Hand
Posts: 129
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
hi Folks,

I have problem in Eclipse...I am using eclipse for J2me.
I want to compile through Ant using javac 1.3 compiler becasue we are importing default package which is not supported in java 1.4. We can set the the Compliance level in Eclipse IDE. But what about Ant ....I am using this



Here only thing which I am not giving is executable path of 1.3 javac executable="/opt/java/jdk1.1/bin/javac" I had done that also but giving me error on default package import ..


Thanks
Please Help Me

[edited to add code tags]
[ May 24, 2005: Message edited by: Jeanne Boyarsky ]
 
author & internet detective
Posts: 41905
909
Eclipse IDE VI Editor Java
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
Moving to the Ant forum
 
Ranch Hand
Posts: 1953
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
When I was doing J2ME, I was using WTK, ANT, and antenna to complete everything.
 
vishwas bhatt
Ranch Hand
Posts: 129
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
hi,

we are using Eclipse and Ant. I wanted to know how can I use javac Task to compile sode with the compliance level of 1.3. And I have installed Eclipse(3.0.1), Ant (1.6.2) and Java (1.4.2).


Thanks
Waiting for reply
reply
    Bookmark Topic Watch Topic
  • New Topic