Win a copy of Functional Reactive Programming this week in the Other Languages forum!
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic

Running JUnit 4 with Ant 1.6.5

 
Amirr Rafique
Ranch Hand
Posts: 324
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
I am trying to run JUnit4 test with Ant 1.6.5. I am getting following error LoggingTest:
Caused an ERROR [junit] No runnable methods [junit] java.lang.Exception: No runnable methods
Below is the JUnit test case
The Ant task is
 
Deon Cravalho
Greenhorn
Posts: 6
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
I realize your posting of the question was a few years back, but thought I would post a response in case someone else was researching the issue and stumbles across this thread:

JUnit 4 is not compatible with Ant 1.6.5. You may find some solutions of how to tweak it, to make it work, but you may have some sacrifices of things such as the JUnit results window.

Suggest upgrading Ant to 1.7, which should be compatible with JUnit 4.
 
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic