• Post Reply Bookmark Topic Watch Topic
  • New Topic

Hello World applet trouble  RSS feed

 
Anonymous
Ranch Hand
Posts: 18944
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Howdy Java Dudes,
I'm using Sun's SDK v1.2.2 006 under RedHat 6.1 and have been
unable to get appletviewer to run "Hello.html" without the ugly
message: "Applet Not Initialized" below the text "Hello World!".
Both my java code and html are exactly as shown on the
Java Tutorial online at: http://www.javasoft.com/docs/books/tutorial/getStarted/cupojava/unix.html
When I run the appletviewer under Sun's JDK 1.3 on a Windows
machine the display shows "Applet Started." just as expected.
(So both the HelloWorld.java and Hello.html files are good.)
I suspect this is some sort of classpath problem, and have
tried passing the classpath to the appletviewer with:
appletviewer -J-classpath -J/usr/local/jdk1.22/xxx Hello.html
I've tried several classpath permutations but have been unable
to find a solution. (Sun's documentation also describes setting
the classpath, but recommends passing it to the tools instead.)
I've also searched the FAQs and newgroups for a solution, but
no one else has reported this problem as far as I can tell.
I wonder ... has anyone else seen this problem?
The applet seems to work fine when viewed with Netscape 4.75.
I've not yet tried blackdown or IBM versions.
Thanks very much for any thoughts on this.
Mike
 
  • Post Reply Bookmark Topic Watch Topic
  • New Topic
Boost this thread!