• Post Reply Bookmark Topic Watch Topic
  • New Topic

Internet Connection.  RSS feed

 
DipakPatel
Greenhorn
Posts: 3
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hi I am in Canada.
I have linux installed in my machine,and also have windows me.I have my internet connection setup in Windows Me and works fine and now I wanna have access to internet through linux also.My modem is connected to port 3.Any one has any idea,how do i do it.
I tried doing on linux but it always gave me response that your modem is busy.If somebody can help me in this case, I will appreciate.
Dipak
 
Daniel Craig
Greenhorn
Posts: 7
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
You will need to route traffic from the winme machine to your linux box. Try winroute
Or do it properly and have the Linux box up front with Winme behind as a desktop PC.
 
Greg Harris
Ranch Hand
Posts: 1012
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
i think he has them on the same machine...
i had some problems getting my linux connection to work as well. i recently installed redhat 7.1 and still had to tweek it a little. 7.0 did not recognize my modem, but 7.1 found it with no problems. however, when i set up my ppp dialer, it never connected to the phone line.
i finally looked at the file containing the modem settings (i cannot remember the file name and i do not have my machine here ). the PASSWORD and USERNAME lines were not in the right place... they were at the end of the file, and not at the top with the rest of the modem settings.
i will see what i can find when i get home tonight.
 
DipakPatel
Greenhorn
Posts: 3
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Yes Greg, I have them (Windows me and Linux) on the same machine .How can I make it work on my linux as it works fine with my Winodws partition.
[This message has been edited by DipakPatel (edited May 30, 2001).]
 
Greg Harris
Ranch Hand
Posts: 1012
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
i have Redhat 7.1 so if you have something else, i am not sure how much help i will be. of course, they are not too different.
first: did your linux installation recognize your modem? Redhat 7.0 did not find my modem, but 7.1 found it as i was upgrading.
if so: did you set up your isp phone number, username and password? i had to go into the ppp file and change a couple lines because they were not in the correct place.
if not: you will need to search the web (www.linux.org) for drivers that will work with your modem.
i will find the name of the file i modified when i get home tonight (9:00 pm EST)
 
Frank Carver
Sheriff
Posts: 6920
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
"DipakPatel",
The Java Ranch has thousands of visitors every week, many with surprisingly similar names. To avoid confusion we have a naming convention, described at http://www.javaranch.com/name.jsp .
We require names to have at least two words, separated by a space, and strongly recommend that you use your full real name. Please log in again with a new name which meets the requirements.
Thanks.
 
Greg Harris
Ranch Hand
Posts: 1012
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
the file i edited on my Redhat 7.1 machine was:
/etc/wvdial.conf
it is supposed to look like:

Modem = /dev/ttyS1
Baud = 115200 (or whatever your speed is)
Init1 = ... (specific to your modem)
Init2 = ... (specific to your modem)
Phone = 7705551234 (whatever your isp phone# is)
Username = yourUserName
Password = 1234 (your password)

my file had the correct information, but the Phone, Username and Password lines were with a different block of parameters... i just typed them below my modem settings like above and everything worked perfectly!
your Phone, Username and Password lines may be commented-out with a ";" at the beginning of the line... if so, just delete the ";"
you can start your connection from the command line by typing:

$ wvdial

or you can run it from the GUI.
let me know if this helps.
NO MORE NEED FOR MICROSOFT!!!
 
  • Post Reply Bookmark Topic Watch Topic
  • New Topic
Boost this thread!