• Post Reply Bookmark Topic Watch Topic
  • New Topic

Messed up X  RSS feed

 
sonny kher
Ranch Hand
Posts: 83
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
I think I messed up some permissions while logged in as root and now I cannot log into any of the desktop environment as a non root user (I mean I can log in, but the env is all messed up, I don
t see the start panel and the xterms also have the top panel missing etc etc). Did I change some X11 permissions, whats the first place to start looking?
-thanks
 
Guy Allard
Ranch Hand
Posts: 776
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
sonny - here's what I would do, but please don;t blame me if this does not work or messes things up worse.
- login as root
- cd to the 'normal' user's home directory
- do: ls .* (that's dot-star)
There will be a bunch of directories listed: .Gnome, .kde, etc.
For each one do (for example):
rm -rf .kde
Then login the 'normal' user and startx. The graphic environment S/B reset to all defaults.
An alternative to this approach is to just delete the login id for the normal user, rm -rf his/her home directory, and add the user back.
HTH, Guy
 
sonny kher
Ranch Hand
Posts: 83
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
I've tried adding new users, but it doesn't seem to work. X works only for root, all other users (new or old) see a really messed up environment.
Maybe its time to reinstall, I created a lot of partitions, maybe I could re-install where all X11 files are.
 
Nitin Shivaram
Ranch Hand
Posts: 71
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Sonny,
If you still haven't re-installed Linux, here's what you could try.
vi into '/etc/inittab' file, and look at the line
which says 'id:`aNumber`:initdefault'.
Try setting `aNumber` to 5.
This would make linux start the windowing system everytime it comes up.
hope it works.
 
  • Post Reply Bookmark Topic Watch Topic
  • New Topic
Boost this thread!