• Post Reply Bookmark Topic Watch Topic
  • New Topic
programming forums Java Mobile Certification Databases Caching Books Engineering Micro Controllers OS Languages Paradigms IDEs Build Tools Frameworks Application Servers Open Source This Site Careers Other all forums
this forum made possible by our volunteer staff, including ...
Marshals:
  • Campbell Ritchie
  • Liutauras Vilda
  • Bear Bibeault
  • Jeanne Boyarsky
  • Tim Cooke
Sheriffs:
  • Knute Snortum
  • Junilu Lacar
  • Devaka Cooray
Saloon Keepers:
  • Ganesh Patekar
  • Tim Moores
  • Carey Brown
  • Stephan van Hulst
  • salvin francis
Bartenders:
  • Ron McLeod
  • Frits Walraven
  • Pete Letkeman

help please...  RSS feed

 
Ranch Hand
Posts: 126
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hi all:
What is the best way to deliver an application to the customer (in the form of jar file or ...)?
If jar file is the best form, then how shd i create a jar file for my application on hp-ux 10.20
My application is using two other jar files (vendor-provided) say x.jar and y.jar
In win-nt, i created a jar file (say app.jar) using the command from the directory (say proj) which contains all the files needed for this project
c:\proj>jar -cvf app.jar *
Then to execute a class file (say main.class which contains the application's entry point)
C:\proj>java -classpath app.jar;x.jar;y.jar main
The above commands worked in win-nt and it had started the application but these commands are not working in hp-ux 10.20....could anyone help me please?
I tried the following 2 commands in hp-ux, they are also NOT working
java -classpath /opt/java/lib/classes.zip:app.jar:x.jar:y.jar main
jre -classpath /opt/java/lib/classes.zip:app.jar:x.jar:y.jar main

Thanks a lot in advance...
Uma
 
Ranch Hand
Posts: 145
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
What error message are you getting? Not that I may be able to help, but your question is not complete.
Mathew :roll:
 
Uma Viswanathan
Ranch Hand
Posts: 126
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Thanks a lot for the reply...
I could not see any error message. The problem was 'it was not executing the application'. Anyways, i had corrected it now.
 
  • Post Reply Bookmark Topic Watch Topic
  • New Topic
Boost this thread!