• Post Reply Bookmark Topic Watch Topic
  • New Topic

Red Hat 8.0 GCJ 1.3.1  RSS feed

 
Unnsse Khan
Ranch Hand
Posts: 511
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hello, on my previous distribution (Red Hat 7.3), I had the Sun Microystem's Java 2 SDK 1.4.0_01 installed at /usr/local/java/j2sdk1.4.0_01
I had that particular directory set as my $JAVA_HOME environmental variable in
/root/.bash_profile
Now... when I type:
java -version
Its the Java 1.3.1 version installed with Free Software Foundation's gcj
Its overriding the one that I have set up for home use. I would really appreciate it if someone could tell me how to uninstall this particular Java from my machine (as it is overriding my setting for JAVA_HOME in my .bash_profile).
When I typed: (as root)
rpm -e jdkgcj
an error message stated:
error: Failed dependencies:
jdkgcj >= 0.2.2 is needed by (installed) kdebinding-qtjava-3.0.3-1
I am confused and would appreciate it if someone could help me regarding this.
 
Adam Hardy
Ranch Hand
Posts: 567
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
jdkgcj is being used by kde-bindings. That's why rpm won't let you de-install it.
I don't know what kde-bindings does.
Try
rpm -V --whatrequires kdebinding-qtjava-3.0.3-1
and it will tell you if any other packages are using kdebinding - you may be able to de-install it with no further problems.
Alternatively, you could sort out your JAVA environment to ignore it.
You need to have $JAVA_HOME/bin in your $PATH, and to get rid of the setting in your PATH to the other java which you are getting.
 
  • Post Reply Bookmark Topic Watch Topic
  • New Topic
Boost this thread!