• Post Reply Bookmark Topic Watch Topic
  • New Topic

linux and eclipse  RSS feed

 
Ben Buchli
Ranch Hand
Posts: 83
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
hi, anybody know how to install and run eclipse in linux? i'm running mandrake 10.0

thanks,
ben
 
Stefan Wagner
Ranch Hand
Posts: 1923
Linux Postgres Database Scala
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Yes. Where's the question?
There are two versions, one is gtk, which is what I use.
Download, unzip, - I remember: chmod a+x ...eclipse, -
 
Ben Buchli
Ranch Hand
Posts: 83
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
thanks for the reply.
i have the jdk installed and it works, but when i start eclipse the splash screen shows up but then i get an error...
which version have you installed??
 
Ernest Friedman-Hill
author and iconoclast
Sheriff
Posts: 24217
38
Chrome Eclipse IDE Mac OS X
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Originally posted by Ben Buchli:
thanks for the reply.
i have the jdk installed and it works, but when i start eclipse the splash screen shows up but then i get an error...


If you tell us what the error is perhaps we could help you get past it.
 
Ben Buchli
Ranch Hand
Posts: 83
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
i will post as much information as i can tonight. thanks!
 
Ben Buchli
Ranch Hand
Posts: 83
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
alright guys, thanks for the help. i got it to work. however, i didnt get the project version 3.0 to work, only 2.1.3.
One more question, though: it's the first time i'm using linux and java on linux. anyway, i'm using jdk 1.5 beta, and somehow, when i have an arrayList it doesnt let me use size(), get(), add(), and so forth... any ideas?

thanks,
ben
 
Ernest Friedman-Hill
author and iconoclast
Sheriff
Posts: 24217
38
Chrome Eclipse IDE Mac OS X
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Again, more details on exactly how it "doesn't let you use" these methods would help. What error messages or other indications are you seeing?
 
Stefan Wagner
Ranch Hand
Posts: 1923
Linux Postgres Database Scala
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
The last time I installed eclipse 3.0.0 it was M8 (gtk).
I was told to use a jdk1.4 vm to run eclipse.
I was told, that it is possible, to program against a 1.5 java, if I install cheetah, which needed an eclipse-Nightly-build, but that it is very beta (and I didn't get it working).

I guess you need a 1.4 jre at least, to run eclipse.
Than you need the newest (unstable) version of eclipse, to run 1.5er code.
There is a newsgroup: news.eclipse.org which might be more up to date.
[ May 17, 2004: Message edited by: Stefan Wagner ]
 
Ben Buchli
Ranch Hand
Posts: 83
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
it says "method size() is undefined for the type ArrayList", and "method get(int) is undefined for the type ArrayList".
there were also other errors similar to the ones mentioned above, that i could fix with typecasting. it seemed strange but worked...

thanks for any help...
 
It is sorta covered in the JavaRanch Style Guide.
  • Post Reply Bookmark Topic Watch Topic
  • New Topic
Boost this thread!