• Post Reply Bookmark Topic Watch Topic
  • New Topic

PLEASE HELP Suse Login problem  RSS feed

 
Jesse Torres
Ranch Hand
Posts: 985
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
I am running Suse 9.2 pro. During boot screen, I select Suse 9.2. My computer then goes through the boot sequence normally. However, right before loading the KDE, Suse prompts me to enter my username and password. In other words I am presented with a dialog box that asks me to enter my Username + Password and then hit Login or Menu. So I enter my username + password and the hit Login. The dialog disappears w/o any errors. But then the login dialog reappears. I then again enter my username + password. The dialog once again goes away w/o incident. But then the login dialog reappears. I am unable to login.

I am still learning. What is happening? How can I log-in?

Please Help
 
Jesse Torres
Ranch Hand
Posts: 985
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
I am able to login if I enter the following username + password

Username: root
Password: xxxxxxxxxxxxxxxxxxx

Please help,
 
Peter Rooke
Ranch Hand
Posts: 900
7
Java Linux Spring
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Firstly - don't panic! Since you are able to login as the 'Super User' (root), you can perform any system administration tasks.

I am assuming that the login screen you are talking about is a graphical login screen ["However, right before loading the KDE, Suse prompts me to enter my username and password."], and not a text based one.

If so then login as root - the superuser, who role is to carry out administration. I am guessing that you just need to reset the users password. Do this by either:

1) From the KDE menu (similar to windows start button) 'Start Applications' => 'Control Center' => 'Yast2 Modules' => 'Security and Users' => 'Edit and Create Users' => (A dialog should be displayed) Select User in the list => Click the 'Edit' button => Change the password in the text box => Next button => click Finish button.

2) Bring up a shell prompt (kconsole etc). Type the command
passwd <username> - then enter the new password (twice)
- (watch, so that you do not change the root password by
typing 'passwd' without the
username)

If you still are getting no where, post again.

The real fun, starts when you cannot login as root! - Don't go there!
 
Petr Blahos
Ranch Hand
Posts: 131
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Peter, I wouldn't be sure that a wrong password is the reason.
I think he would get an error message of some kind. (But Jesse,
give it a try anyway)

Jesse, well, this is tricky. It appears to me that you are
automaticaly logged out straight after you have logged in.
But why? There might be too many reasons.

If you as you said don't have much experience in linux, maybe
the easiest solution would be to create a new user and copy
the files from the user that cannot log-in. You will learn
how to create a user, copy files (as root) and change
ownership. You can delete the old user or retain it for finding
out what is wrong later.

Some things to try:
Try to choose a different window manager when logging in. I don't
know how to select that in SuSE but there will be something like
failsafe, or twm, or maybe windowmaker.
Press Ctrl Alt F2 and try to enter your login name
and password there. Did it work? It was a console login and
if it worked then the failure in X11 is X11 or KDE or what
specific.

Hope it helps,
Petr
 
Jesse Torres
Ranch Hand
Posts: 985
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Originally posted by Peter Rooke:
Firstly - don't panic! Since you are able to login as the 'Super User' (root), you can perform any system administration tasks.

I am assuming that the login screen you are talking about is a graphical login screen ["However, right before loading the KDE, Suse prompts me to enter my username and password."], and not a text based one.

If so then login as root - the superuser, who role is to carry out administration. I am guessing that you just need to reset the users password. Do this by either:

1) From the KDE menu (similar to windows start button) 'Start Applications' => 'Control Center' => 'Yast2 Modules' => 'Security and Users' => 'Edit and Create Users' => (A dialog should be displayed) Select User in the list => Click the 'Edit' button => Change the password in the text box => Next button => click Finish button.

2) Bring up a shell prompt (kconsole etc). Type the command
passwd <username> - then enter the new password (twice)
- (watch, so that you do not change the root password by
typing 'passwd' without the
username)

If you still are getting no where, post again.

The real fun, starts when you cannot login as root! - Don't go there!


Thanks for your help. I tried both of your tips. Unfortunately, it didn't work anymore suggestions?

Thanks
 
Peter Rooke
Ranch Hand
Posts: 900
7
Java Linux Spring
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Firstly we need to know if its a problem with the user account, so try Petr Blahos above suggestion - login as the user in text mode, and try a different windows manager (from the drop down below the password text field).

If not post again, give us as much information as possible (within reason )

As you must have sucessfully logged in as the root superuser using KDE, to change the password via YAST2, X and KDE must be working ok.

My local football (soccer) team are playing tonight - but I'll monitor this thread.

[ November 25, 2004: Message edited by: Peter Rooke ]
[ November 25, 2004: Message edited by: Peter Rooke ]
 
Peter Rooke
Ranch Hand
Posts: 900
7
Java Linux Spring
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Jesse, if you are interested in Linux have a look at
Cygwin - its a "Linux-like environment for Windows", so not a true linux distribution, but an emulation layer that works inside of windows.

You will not get the same functionality of SuSE, like KDE (etc) - but you can play around with bash, and learn Linux.
 
Jesse Torres
Ranch Hand
Posts: 985
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
My problems all started after the installation of Yahoo Instant Messenger. For example, I downloaded the Yahoo IM installation file to my home folder. Then I right clicked the file and selected "Install with Yast" choice. After selecting "Install with Yast", Suse prompted me to insert Suse CD1. I then inserted CD1 as prompted. Upon rebooting, I am now consistently asked to enter a username and password. I am going to reinstall Suse 9.2.
 
Jesse Torres
Ranch Hand
Posts: 985
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Originally posted by Peter Rooke:
Jesse, if you are interested in Linux have a look at
Cygwin - its a "Linux-like environment for Windows", so not a true linux distribution, but an emulation layer that works inside of windows.

You will not get the same functionality of SuSE, like KDE (etc) - but you can play around with bash, and learn Linux.


Thanks for your advice. However, I'd rather have a full Linux distribution.
 
Peter Rooke
Ranch Hand
Posts: 900
7
Java Linux Spring
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
It just could be that the "Yahoo Instant Messenger" - is asking for your Internet service provider username and password. It would do this (I think) so it could set up connectivity to Internet at boot time. I've never used this software so this is just guesswork.

Maybe just as well to reinstall.

PS - I've heard this rumor (story). That one of the original Unix developers (Ken Thomson - I think) build a car, with only one red LED on the dashboard. If anything goes wrong, it flashes. If it does flash, he stated he always knows what is wrong, as he build the car.
 
Jesse Torres
Ranch Hand
Posts: 985
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Originally posted by Peter Rooke:
It just could be that the "Yahoo Instant Messenger" - is asking for your Internet service provider username and password. It would do this (I think) so it could set up connectivity to Internet at boot time. I've never used this software so this is just guesswork.

Maybe just as well to reinstall.

PS - I've heard this rumor (story). That one of the original Unix developers (Ken Thomson - I think) build a car, with only one red LED on the dashboard. If anything goes wrong, it flashes. If it does flash, he stated he always knows what is wron, as he build the car.


You were absolutely correct. My Yahoo IM installation was setup to login on X Window login. I reinstalled Suse 9.2 Pro. I also deselected Yahoo IM option to autologon.

Thanks so much for all of your help. I want to fully make the transition to Linux and abandon Microsoft.

Thanks very much,
 
michael amex
Greenhorn
Posts: 1
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hallo Jesse,

I have the same problem with you (I installed Yahoo Messenger, and SUSE 9.2 refused me from logging in to the system). I downloaded the precompiled for RedHat (rh9.ymessenger-1.0.4-1.i386.rpm) . But if I'm logging in after ctrl+alt+F1, it works, but I can't get into my KDE (I've tried kde and startkde). As root it's no problem at all.
I would like to ask if someone would have an idea for this problem, because I think reinstall is not the best way for this...

Thanks in advance.
Michael
 
Sonny Gill
Ranch Hand
Posts: 1211
IntelliJ IDE Mac
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hmm..I once ran into a similar problem, and could not find the reason.
What I did was,

1. log in as root
2. rename my home directory to something else
3. create an empty directory to replace it
4. log out, and log back in as myself..and bingo it worked.

I guess there was some problem in the configuration files in my home directory.
 
Peter Rooke
Ranch Hand
Posts: 900
7
Java Linux Spring
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
I'm thinking that your Yahoo software is trying to connect to the internet, by using some of the operating system services. However these services (maybe ppp) do require the username and password for your internet service provider. Maybe the problem will be solved by looking at the underlining software that handles the connectivity to the internet. It must be able to configure it so that it knows how to find the ISP details.

I have little experience in this area, (yet) - so I cannot help further. However I may look into this latter (if I get the time), when I can get onto a linux box.
 
Ellen Zhao
Ranch Hand
Posts: 581
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hi all,

I got exactly the same problem as Jesse's days ago when I installed the yahoo IM for linux. But solved it in two minutes. You guys didn't pay enough attention to what the yahoo IM said after the installation. It does tell you it would add an entry into some file called .x... (i cannot remember the file name now, but I did remember at that day, that's why i solved it so quickly). And, that .x...file is for the dist Fedora (red hat) I suppose. So that I simply signed in with root account,

cd /home/ellen/
ls -la

then I found that evil .x... file, deleted it (delete the whole file. cos it's in fact empty). Done. when I tried logging in again, no problem at all.

Before I used SuSE 9.2 pro, I had been with Fedora Core for a while. I really liked it, it's a more standard Linux than SuSE, I have to say (when you learn SuSE, you learn SuSE, but not linux). If Fedora Core hasn't gone too ...(don't want to get started, if you've used Fedora Core 2, you know what I want to say) I wouldn't switched to SuSE (I tried Mandrake, but it doesn't support my motherboard).

And, Sonny if you are really using SuSE 9.2 you shouldn't have any problem with the wma or wmv file. Check out packman.iu-bremen.de/suse/9.2. You can get the binary package of MPlayer and Lame there, download them and install. Then your SuSE box plays everything.(It's in fact just codec thing) You can simply remove all the other media players.

Regards,
Ellen
[ December 10, 2004: Message edited by: Ellen Zhao ]
 
Sonny Gill
Ranch Hand
Posts: 1211
IntelliJ IDE Mac
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Thanks for the tip Ellen.
I am using Suse 9.1, I had a look at MPlayer a while ago, it looked like a bit of work to get it working, perhaps I wasnt looking at the binary package, I will check it out.
Now I wont have to ask my graphic designer colleague to play the next funny (junk) video file I get in mail
 
Jesse Torres
Ranch Hand
Posts: 985
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Originally posted by Ellen Zhao:
Hi all,

I got exactly the same problem as Jesse's days ago when I installed the yahoo IM for linux. But solved it in two minutes. You guys didn't pay enough attention to what the yahoo IM said after the installation. It does tell you it would add an entry into some file called .x... (i cannot remember the file name now, but I did remember at that day, that's why i solved it so quickly). And, that .x...file is for the dist Fedora (red hat) I suppose. So that I simply signed in with root account,

cd /home/ellen/
ls -la

then I found that evil .x... file, deleted it (delete the whole file. cos it's in fact empty). Done. when I tried logging in again, no problem at all.

Before I used SuSE 9.2 pro, I had been with Fedora Core for a while. I really liked it, it's a more standard Linux than SuSE, I have to say (when you learn SuSE, you learn SuSE, but not linux). If Fedora Core hasn't gone too ...(don't want to get started, if you've used Fedora Core 2, you know what I want to say) I wouldn't switched to SuSE (I tried Mandrake, but it doesn't support my motherboard).

And, Sonny if you are really using SuSE 9.2 you shouldn't have any problem with the wma or wmv file. Check out packman.iu-bremen.de/suse/9.2. You can get the binary package of MPlayer and Lame there, download them and install. Then your SuSE box plays everything.(It's in fact just codec thing) You can simply remove all the other media players.

Regards,
Ellen

[ December 10, 2004: Message edited by: Ellen Zhao ]


Thanks for your advice.
 
  • Post Reply Bookmark Topic Watch Topic
  • New Topic
Boost this thread!