• Post Reply Bookmark Topic Watch Topic
  • New Topic

PDF software for Linux  RSS feed

 
vivien siu
Ranch Hand
Posts: 143
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Does anyone knows if there's any Adobe Acrobat or Professional software that can be used on Linux platform?

I need to find a software which enables me to convert PDF from version 1.2 to 1.4. Although Adobe Reader can be used on Linux however it cannot do the conversion. Any info will be very appretiated. Thank you!
 
Ulf Dittmer
Rancher
Posts: 42972
73
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
I'm curious what the requirement is for the conversion from 1.2 to 1.4? That change in itself does not alter the contents of the file.
 
vivien siu
Ranch Hand
Posts: 143
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
:roll: company requirement. Coz the PDF files need to be added watermark, stamped, ecnrypted and digitally signed.

Also the PDFs will be opened in Adobe 6.0 and above so they want us to do it
 
Ulf Dittmer
Rancher
Posts: 42972
73
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
The iText library can perform those actions on an existing PDF file.
[ February 23, 2006: Message edited by: Ulf Dittmer ]
 
vivien siu
Ranch Hand
Posts: 143
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hi Ulf,

I have used iText, it will work as I wanted to if the PDF files are not corrupted. However I'm having problems now bcoz it seems that there are errors with the xref table of the PDFs. I have to find a way to fix this error somehow.

Thank you for your help!
 
Junaid Saeed
Greenhorn
Posts: 2
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hi,

Can you provide me information how to repair the corrupted pdf through an API. I am also having this problem.

Regards,
Junaid
 
  • Post Reply Bookmark Topic Watch Topic
  • New Topic
Boost this thread!