• Post Reply Bookmark Topic Watch Topic
  • New Topic
programming forums Java Mobile Certification Databases Caching Books Engineering Micro Controllers OS Languages Paradigms IDEs Build Tools Frameworks Application Servers Open Source This Site Careers Other Pie Elite all forums
this forum made possible by our volunteer staff, including ...
Marshals:
  • Campbell Ritchie
  • Tim Cooke
  • Ron McLeod
  • Jeanne Boyarsky
  • Paul Clapham
Sheriffs:
  • Liutauras Vilda
  • Henry Wong
  • Devaka Cooray
Saloon Keepers:
  • Tim Moores
  • Stephan van Hulst
  • Tim Holloway
  • Al Hobbs
  • Carey Brown
Bartenders:
  • Piet Souris
  • Mikalai Zaikin
  • Himai Minh

set JAVA_HOME

 
Ranch Hand
Posts: 218
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
Hi there,
on a Suse 10.1 I'm trying to run JBoss 4 which at the startup gives me the following message

run.sh: Missing file: /lib/tools.jar
run.sh: Unexpected results may occur. Make sure JAVA_HOME points to a JDK and not a JRE.


ok, then I checked where actually the jdk was
/opt/jdk1.5.0_07

from the console
echo $JAVA_HOME
/usr/lib/jvm/java


so, I tried to set the JAVA_HOME
export JAVA_HOME=/opt/jdk1.5.0_07
export PATH=$JAVA_HOME/bin:$PATH


just a quick check
which java
/opt/jdk1.5.0_07/bin/java
which javac
/opt/jdk1.5.0_07/bin/javac


fine.....I though
but as soon as log out and log in all the java enviroments back as were before.
What's going on? How can I solve my problem?
(how can I set that var for every user?)

Thanks in advance
 
author and iconoclast
Posts: 24204
44
Mac OS X Eclipse IDE Chrome
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
You have to edit the appropriate configuration files -- just setting the variables at the prompt affects your current session only.

I'm going to move this to our Linux/UNIX forum, where someone with a little more time than me will explain the details to you. In the meantime, you could try running "info bash" and reading the section on configuration files.
 
Alessandro Ilardo
Ranch Hand
Posts: 218
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
ok, I did more or less the same thing editing a file called /etc/profile.local and it works pretty fine.

So, now the JAVA_HOME env seems to correct and when I try to run JBoss as nyself I don't get anymore that error

Boss Bootstrap Environment

JBOSS_HOME: /etc/jboss-4.0.5.GA

JAVA: /opt/jdk1.5.0_07/bin/java

JAVA_OPTS: -Dprogram.name=run.sh -server -Xms128m -Xmx512m -Dsun.rmi.dgc.client.gcInterval=3600000 -Dsun.rmi.dgc.server.gcInterval=3600000

CLASSPATH: /etc/jboss-4.0.5.GA/bin/run.jar:/opt/jdk1.5.0_07/lib/tools.jar


but when I try to run it as jboss (system user) using the command
sudo -u jboss ./run.sh
I still have the same problem.
run.sh: Missing file: /lib/tools.jar
run.sh: Unexpected results may occur. Make sure JAVA_HOME points to a JDK and not a JRE.
=========================================================================

JBoss Bootstrap Environment

JBOSS_HOME: /etc/jboss-4.0.5.GA

JAVA: java

JAVA_OPTS: -Dprogram.name=run.sh -server -Xms128m -Xmx512m -Dsun.rmi.dgc.client.gcInterval=3600000 -Dsun.rmi.dgc.server.gcInterval=3600000

CLASSPATH: /etc/jboss-4.0.5.GA/bin/run.jar:/lib/tools.jar


It seems that user can't get the enviroment which should be visible to everybody. I'm not sure if everybody includes system user as well.
 
Saloon Keeper
Posts: 25841
184
Android Eclipse IDE Tomcat Server Redhat Java Linux
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
Unlike Windows, Linux has some very definite ideas of when to propagate environment variables and how. And, in the case of the "su" command, you can specify either that the su user be initialized as a clone of the current user environment, as a fresh login of the indicated user or as a completely clean environment. And maybe one or 2 other options.

Actually, it's really bad practice to depend on environmental setups when launching system init scripts, and you're seeing some of the reasons why.

A useful alternative is to setup the environment for a system task/daemon in /etc files. For example, create an /etc/default/jboss.conf file and define JAVA_HOME, JBOSS_HOME and whatever other environment variables you find useful in there. That allows you to make the init script itself portable. You just make the init script "source" the config file, leaving only invariant items in the init script.

JBoss's run.sh isn't done quite like the scripts in /etc/init.d, but it's close enough you can use that same general strategy.
 
Alessandro Ilardo
Ranch Hand
Posts: 218
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
thank you very much for your explanation. I apreciated.
 
Ranch Hand
Posts: 147
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
...
reply
    Bookmark Topic Watch Topic
  • New Topic