• Post Reply Bookmark Topic Watch Topic
  • New Topic
programming forums Java Mobile Certification Databases Caching Books Engineering Micro Controllers OS Languages Paradigms IDEs Build Tools Frameworks Application Servers Open Source This Site Careers Other Pie Elite all forums
this forum made possible by our volunteer staff, including ...
Marshals:
  • Campbell Ritchie
  • Jeanne Boyarsky
  • Ron McLeod
  • Paul Clapham
  • Junilu Lacar
Sheriffs:
  • Rob Spoor
  • Liutauras Vilda
  • Tim Cooke
Saloon Keepers:
  • Tim Moores
  • Piet Souris
  • Tim Holloway
  • Jj Roberts
  • Stephan van Hulst
Bartenders:
  • Himai Minh
  • Carey Brown
  • Frits Walraven

Running ANT on Linux

 
Ranch Hand
Posts: 38
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
Hello everyone!

I need your help on running the ant task on Linux box. It might sound simple (and so it was for me), however, things turned out to be rather ugly. Any kind of help is appreciated. Now, here's what I'm trying to do:

Suppose I have a build.xml script, which includes a following task:

xslt basedir="..."
destdir="..."
includes="*.*"
extension=".xml
style="ContentCleanup.xsl"

Basically, what it supposed to is to grab all the XML files from the base directory, run it through the aforementioned XSL file and output the results to the destination directory. Short and simple. However, there are thousands of these files to process and to get this done quickly I have to set the ANT_OPTS to something like this:
set ANT_OPTS=-Xmx1024m

That's on Windows and it works fine and very fast, however, after moving all my code to Linux box AND setting ANT_OPTS (export set ANT_OPTS=-Xmx1024m), the process runs extremely slow, as if ANT_OPTS have been ignored completely. Running "top" command, I noticed the following:

VIRT RES SHR %CPU %MEM
114m 65m 16m 101 2.6

It appears that one of those items (I think RES) should be increased to run the process faster, but how? And why ANT_OPTS do not work for this XSLT task? Just for comparison: my build script also calls a java process of my own, using <java> task and I'm passing the memory usage info in these arguments:
jvmarg value="-Xms1024M"
jvmarg value="-Xmx1024M"

This java task works fine on Linux and RES shows exactly what I've excepted: 1024m. So, why not with the XSLT task?

I hope it doesn't sound confusing and I hope there's a rational explanation to this. I'm very new to Linux, especially using ant, and any help would be appreciated.

Please, throw any advises, because, frankly, I'm running out of ideas!


PS. I'm sorry, but apparently I can't put XSLT and JVMARG tasks in brackets(<>), but I hope you'll get the idea.
[ April 24, 2008: Message edited by: Boris Golman ]
 
You showed up just in time for the waffles! And this tiny ad:
Building a Better World in your Backyard by Paul Wheaton and Shawn Klassen-Koop
https://coderanch.com/wiki/718759/books/Building-World-Backyard-Paul-Wheaton
reply
    Bookmark Topic Watch Topic
  • New Topic