Win a copy of Pro Spring MVC with WebFlux: Web Development in Spring Framework 5 and Spring Boot 2 this week in the Spring forum!
  • Post Reply Bookmark Topic Watch Topic
  • New Topic
programming forums Java Mobile Certification Databases Caching Books Engineering Micro Controllers OS Languages Paradigms IDEs Build Tools Frameworks Application Servers Open Source This Site Careers Other Pie Elite all forums
this forum made possible by our volunteer staff, including ...
Marshals:
  • Campbell Ritchie
  • Ron McLeod
  • Paul Clapham
  • Jeanne Boyarsky
  • Liutauras Vilda
Sheriffs:
  • Rob Spoor
  • Bear Bibeault
  • Tim Cooke
Saloon Keepers:
  • Tim Moores
  • Stephan van Hulst
  • Tim Holloway
  • Carey Brown
  • Piet Souris
Bartenders:
  • Frits Walraven
  • Himai Minh

Tomcat and Apache

 
Ranch Hand
Posts: 72
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
Hello All,

I have installed Tomcat on my Mac. When I go to http://localhost:8080 I get the default Tomcat screen. I have written a small web app that works fine on my machine. But when I go to any other machine in our network, the default page appears fine, but the webapp generates a "A connection failure has occurred." message. It works fine on my Mac, so I am guessing there is a configuration setting that needs changing.

So, my question is, is this something in the default Mac installation of Tomcat and Apache? Or is it more generic to the Tomcat? And if it is that, can someone (Bear?) move this topic to the best forum?

Thanks,

Elton
 
blacksmith
Posts: 1332
2
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
Probably the firewall. For security, OS X ships with a pretty conservative firewall. And if you do turn Personal Web Sharing on, I think that Apache by default serves from port 80.

Open the System Preferences application and click on "Sharing". Click on "Firewall | New" to create a new tunnel to allow port 8080.
 
Elton Hughes
Ranch Hand
Posts: 72
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
Hello Warren,

You are correct. It was the firewall. Once that port was opened up, it worked like a charm.

Thanks!



Elton
[ February 08, 2005: Message edited by: Elton Hughes ]
 
You are HERE! The other map is obviously wrong. Better confirm with this tiny ad:
Thread Boost feature
https://coderanch.com/t/674455/Thread-Boost-feature
reply
    Bookmark Topic Watch Topic
  • New Topic