• Post Reply Bookmark Topic Watch Topic
  • New Topic
programming forums Java Mobile Certification Databases Caching Books Engineering Micro Controllers OS Languages Paradigms IDEs Build Tools Frameworks Application Servers Open Source This Site Careers Other all forums
this forum made possible by our volunteer staff, including ...
Marshals:
  • Campbell Ritchie
  • Paul Clapham
  • Ron McLeod
  • Liutauras Vilda
  • Bear Bibeault
Sheriffs:
  • Jeanne Boyarsky
  • Tim Cooke
  • Devaka Cooray
Saloon Keepers:
  • Tim Moores
  • Tim Holloway
  • Piet Souris
  • salvin francis
  • Stephan van Hulst
Bartenders:
  • Frits Walraven
  • Carey Brown
  • Jj Roberts

JDK 1.4 Updates broke something on OS X Tiger

 
Ranch Hand
Posts: 511
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hello again,

I am using a G4 PowerBook running OS X Tiger... Ran the software update, last night, and discovered that Apple had updates for the JDK 1.3 & 1.4.2.

Figuring that I might be in project which requires these versions, I chose to allow the software update application to download and install these respective patches.

Well, earlier today, I was trying to invoke a simple Ant build script and received the following error:



As one can, see my Ant process became paused...

Since, I had installed these updates, last night, and had written an Ant build script (which worked), yesterday, I assumed / guessed that it was the updates that caused this problem.

Therefore, I checked my JAVA_HOME and .bash_profile:



When I did a simple check of "java -version", this is what I got:



My questions:

1. Which version am I using?

2. Why is Ant's functionality broken?

3. Has anyone experienced the same problem after downloading & installing these updates?

4. How do I switch my "java -version" to point to JDK 1.5 ($JAVA_HOME)?

Any tips and suggestions will be greatly appreciated...

Many, many thanks!
 
Unnsse Khan
Ranch Hand
Posts: 511
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Ok...

I switched the CurrentJDK to 1.5.0 by doing this:

1. sudo su root
2. cd /System/Library/Frameworks/JavaVM.framework/Versions
3. rm CurrentJDK
4. ln �s 1.5.0 CurrentJDK
5. exit

Ok, now when I re-ran Terminal and typed java -version, I still had the same error!



Why is it stating: "HotSpot not at correct virtual address. Sharing disabled."? Has anyone experienced this? Everything was working two days, ago. This all happened after I downloaded & installed the JDK 1.3 & 1.4.2 patches offered via the Software Update utility from Apple.

I am unable to even use Ant, now, because of this...

Hopefully, someone could suggest something?

Kindest regards,
 
Sheriff
Posts: 11343
Mac Safari Java
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Some users on the Apple boards have reported that using Pacifist with the latest Java 5.0 update resolves the issue.
[ September 21, 2005: Message edited by: marc weber ]
 
But how did the elephant get like that? What did you do? I think all we can do now is read this tiny ad:
Building a Better World in your Backyard by Paul Wheaton and Shawn Klassen-Koop
https://coderanch.com/wiki/718759/books/Building-World-Backyard-Paul-Wheaton
reply
    Bookmark Topic Watch Topic
  • New Topic