• Post Reply Bookmark Topic Watch Topic
  • New Topic
programming forums Java Mobile Certification Databases Caching Books Engineering Micro Controllers OS Languages Paradigms IDEs Build Tools Frameworks Application Servers Open Source This Site Careers Other Pie Elite all forums
this forum made possible by our volunteer staff, including ...
Marshals:
  • Campbell Ritchie
  • Jeanne Boyarsky
  • Ron McLeod
  • Paul Clapham
  • Liutauras Vilda
Sheriffs:
  • paul wheaton
  • Rob Spoor
  • Devaka Cooray
Saloon Keepers:
  • Stephan van Hulst
  • Tim Holloway
  • Carey Brown
  • Frits Walraven
  • Tim Moores
Bartenders:
  • Mikalai Zaikin

Simple animated GIF ? - Why preloading doesn't work in IE

 
Ranch Hand
Posts: 41
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
Does anyone know why when I pre-load an animated .gif in IE, the animation doesn't appear on the page when I ask for it?

My code is


The correct image does show up, but the animation doesn't work. If I open the image from my directory with IE, it does show the animation.

Also, the animation still works in Mozilla.

Any help is appreciated.
 
Ron Perich
Ranch Hand
Posts: 41
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
I came up with a work-around cause IE won't show the animation during the post. I create a child window when the page loads and immediately close it. Then, when they start to do the long-lived process, I open the same child window again and put the animated gif on it. When it comes back to the page, it automatically closes it.
 
reply
    Bookmark Topic Watch Topic
  • New Topic