• Post Reply Bookmark Topic Watch Topic
  • New Topic
programming forums Java Mobile Certification Databases Caching Books Engineering Micro Controllers OS Languages Paradigms IDEs Build Tools Frameworks Application Servers Open Source This Site Careers Other all forums
this forum made possible by our volunteer staff, including ...
Marshals:
  • Campbell Ritchie
  • Liutauras Vilda
  • Tim Cooke
  • Jeanne Boyarsky
  • Bear Bibeault
Sheriffs:
  • Knute Snortum
  • paul wheaton
  • Devaka Cooray
Saloon Keepers:
  • Tim Moores
  • Stephan van Hulst
  • Ron McLeod
  • Piet Souris
  • Ganesh Patekar
Bartenders:
  • Tim Holloway
  • Carey Brown
  • salvin francis

Happy New Year! Welcome to our new forums!

 
Ranch Hand
Posts: 1374
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Thanks Jeanne!

Jeanne Boyarsky wrote:...And looking at Java in General (beginner) has a whole page of posts from today alone.[edited to add attachment]


Not really the whole page but only few (3-4) new questions. I think you mixed it with "Last Post"?
 
author & internet detective
Posts: 39435
768
Eclipse IDE VI Editor Java
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator

Vishal Pandya wrote:Not really the whole page but only few (3-4) new questions. I think you mixed it with "Last Post"?


Yes. You are correct.
 
Sheriff
Posts: 6379
1124
IntelliJ IDE jQuery Eclipse IDE Postgres Database Tomcat Server Chrome Google App Engine
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Wow! this is really great approach. I know that I'm very late to the party, but let me comment now. Today is the first day I visit JavaRanch, after this migration. Actually this is a really successful and great migration from old UBB software to the new JForum software. Personally I like this implementation, including the new set of emotions, the 'preview' feature, and especially the private message notification feature, and the quick reply feature. In addition to that I found that there are lot of new features implemented for this new site.

Finally, I would like to thank Jeanne, Ernest, Paul, and everyone else who helped to make this great transition. Thanks to Paul Wheaton for providing this great service for free.
 
Author
Posts: 3443
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
I like the new look and feel and the fetaures. Well done.
 
Sheriff
Posts: 9643
42
Android Google Web Toolkit Hibernate IntelliJ IDE Spring Java
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator

Devaka Cooray wrote:Personally I like this implementation, including the new set of emotions, the 'preview' feature, and especially the private message notification feature, and the quick reply feature.



+1
 
Ankit Garg
Sheriff
Posts: 9643
42
Android Google Web Toolkit Hibernate IntelliJ IDE Spring Java
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hey why does the last post column in the list of posts have such large font. Is it temporary or permanent. If it is permanent, then I think it looks very weird so please please change it.

Thanks...
 
Ranch Hand
Posts: 757
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator

Ankit Garg wrote:Hey why does the last post column in the list of posts have such large font. Is it temporary or permanent. If it is permanent, then I think it looks very weird so please please change it.

Thanks...



+1
 
author and iconoclast
Posts: 24203
43
Mac OS X Eclipse IDE Chrome
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator

Ankit Garg wrote:Hey why does the last post column in the list of posts have such large font. Is it temporary or permanent. If it is permanent, then I think it looks very weird so please please change it.



Yep.
 
Ranch Hand
Posts: 2102
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hi, If we notice something that might need improvement in the new forum system, to where do we report this? (email, forum, etc.)
 
Jeanne Boyarsky
author & internet detective
Posts: 39435
768
Eclipse IDE VI Editor Java
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator

Jesus Angeles wrote:Hi, If we notice something that might need improvement in the new forum system, to where do we report this? (email, forum, etc.)


This forum is good.
 
Jesus Angeles
Ranch Hand
Posts: 2102
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator

Jeanne Boyarsky wrote:

Jesus Angeles wrote:Hi, If we notice something that might need improvement in the new forum system, to where do we report this? (email, forum, etc.)


This forum is good.



I mean, if we notice something that is a possible bug, to whom do we report this?

(An example is the attached print-screen; in my 'My Posts', one topic is displayed twice.)
untitled.JPG
[Thumbnail for untitled.JPG]
 
Ernest Friedman-Hill
author and iconoclast
Posts: 24203
43
Mac OS X Eclipse IDE Chrome
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator

Jesus Angeles wrote:
(An example is the attached print-screen; in my 'My Posts', one topic is displayed twice.)



That's a list of posts, not a list of threads. The two posts you made to that thread are listed separately.
 
Jesus Angeles
Ranch Hand
Posts: 2102
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
I see. Thanks. Congrats to all for the great job!
 
Ranch Hand
Posts: 163
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator

so this is why it suddenly looked different. cool!

congrats to the dev team and a happy new year to all!
great job!!
 
Ranch Hand
Posts: 339
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
May I ask how long did it take To create the New Forum ? I'm really curious about that one.



Jose
 
Ernest Friedman-Hill
author and iconoclast
Posts: 24203
43
Mac OS X Eclipse IDE Chrome
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator

Jose Campana wrote:May I ask how long did it take To create the New Forum ? I'm really curious about that one.



Read the story here.
 
Greenhorn
Posts: 11
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
congratulations!!
 
Ankit Garg
Sheriff
Posts: 9643
42
Android Google Web Toolkit Hibernate IntelliJ IDE Spring Java
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
What is the limit of greenhorn title after the upgrade?? Earlier it was 40 posts. If it's still 40, then I think this user needs him account to be fixed
 
Sheriff
Posts: 4012
6
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Yep, it's still 40 posts. That must have slipped through during the migration. Thanks for the heads up, we'll get that fixed shortly.
 
Bartender
Posts: 1952
7
Eclipse IDE Java
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator

Jelle Klap wrote:I've been experiencing some latency in the updating of the forum overview pages.
When I reply to a topic in a particular forum, and then return to that forum's topic overview, the 'new post indicator' and 'last post' information for the topic aren't updated.
I have to explicitly update the browser cache for the overview page in order to get a correctly updated view. Anyone else experiencing any cache related problems?



Am I the only one experiencing this problem, because it's really starting to bug me.
I guess it could be proxy server related, although I didn't experience any such problems when visiting with the old forum, or any other forum for that matter.
 
Ernest Friedman-Hill
author and iconoclast
Posts: 24203
43
Mac OS X Eclipse IDE Chrome
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator

Pauline McNamara wrote:Yep, it's still 40 posts. That must have slipped through during the migration. Thanks for the heads up, we'll get that fixed shortly.



30, actually -- and the user is now promoted!
 
author
Posts: 23840
141
jQuery Eclipse IDE Firefox Browser VI Editor C++ Chrome Java Linux Windows
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator

Jelle Klap wrote:
Am I the only one experiencing this problem, because it's really starting to bug me.
I guess it could be proxy server related, although I didn't experience any such problems when visiting with the old forum, or any other forum for that matter.



I did experience some "slowness" during the transition -- but everything is running fine for me now. (and I assuming fine for most of us, from the lack of other complaints).

Can you elborate a bit? Are you saying that you posts are not posted right away? Or the icons are not updated right away?

Henry
 
Jelle Klap
Bartender
Posts: 1952
7
Eclipse IDE Java
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Well, if I reply to this thread and return to the Ranch Office overview page (using the Ranch Office breadcrumb link) the "Last Post" information for this thread will not reflect that my post was added. It will keep displaying the name of the user that replied before me - you in this case. Though, my reply definitely is added to the thread right away, because if I immidiately view the last page of the thread my reply is right there. Its just that the Ranch Office thread overview page isn't refreshed correctly (nor is the main forum overview page). Until I force a browser refresh (CTRL-F5 in IE7) that is.

Edit: Ok, nevermind. It's definitely a proxy issue, because I posted this reply at home, and didn't encouter the problem. However, at work I do encouter it all the time, but as I'm behind an HTTP proxy there, that must to be the cause of the problem. Somehow. Still, weird...
 
Ankit Garg
Sheriff
Posts: 9643
42
Android Google Web Toolkit Hibernate IntelliJ IDE Spring Java
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Well today I was searching for a topic in the SCJP forum but couldn't find it through search facility. SO I decided to look for it manually. But I think the pagination right now is very bad. It only lets you navigate to previous and next page apart from the first 3 and last 3 pages. It is a big pain. Although I was able to figure out the URL scheme and used values in the URL to navigate directly to any page that I liked. Am I missing something or is this the only way to navigate??
 
Bartender
Posts: 4101
63
Hibernate Fedora Chrome
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator

Jelle Klap wrote:Well, if I reply to this thread and return to the Ranch Office overview page (using the Ranch Office breadcrumb link) the "Last Post" information for this thread will not reflect that my post was added. It will keep displaying the name of the user that replied before me - you in this case. Though, my reply definitely is added to the thread right away, because if I immidiately view the last page of the thread my reply is right there. Its just that the Ranch Office thread overview page isn't refreshed correctly (nor is the main forum overview page). Until I force a browser refresh (CTRL-F5 in IE7) that is.



I also experienced the same as Jelle most of the time, though I haven't changed any settings (which are same as when the old forum software was running) and I do have a proxy as well (but it was there previously as well). Most of the time when I replied it redirected to the current thread which I posted but it does not reflecting the latest post. Most probably an proxy issue I guess.
 
Jelle Klap
Bartender
Posts: 1952
7
Eclipse IDE Java
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator

Vijitha Kumara wrote:

Jelle Klap wrote:Well, if I reply to this thread and return to the Ranch Office overview page (using the Ranch Office breadcrumb link) the "Last Post" information for this thread will not reflect that my post was added. It will keep displaying the name of the user that replied before me - you in this case. Though, my reply definitely is added to the thread right away, because if I immidiately view the last page of the thread my reply is right there. Its just that the Ranch Office thread overview page isn't refreshed correctly (nor is the main forum overview page). Until I force a browser refresh (CTRL-F5 in IE7) that is.



I also experienced the same as Jelle most of the time, though I haven't changed any settings (which are same as when the old forum software was running) and I do have a proxy as well (but it was there previously as well). Most of the time when I replied it redirected to the current thread which I posted but it does not reflecting the latest post. Most probably an proxy issue I guess.



Exactly, I'm not aware of an changes to our company's proxy either, and because I never experienced this issue on the old forums I find it a bit odd.
 
Ranch Hand
Posts: 2874
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Its cool cool coooool. Yeah I know, I was sleeping or something.
 
Ernest Friedman-Hill
author and iconoclast
Posts: 24203
43
Mac OS X Eclipse IDE Chrome
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator

Jelle Klap wrote:
Exactly, I'm not aware of an changes to our company's proxy either, and because I never experienced this issue on the old forums I find it a bit odd.



The new-post icons are computed on the server by our new forum software; with UBB, they were computed with Javascript inside your browser. The server-side ones are actually more accurate, but they are subject to page-cache issues such as you're describing. The old client-side ones were often wrong, too, but in a different way, and caches didn't matter.

As far as page caching: can't help you there. For most people, things work as you'd expect. I understand that the old system worked differently for you, but it's definitely an issue on your end, not ours. Perhaps it was the "cgi-bin" in the URL that made your proxy/firewall/page cache not cache the old forum listing pages.
 
Ankit Garg
Sheriff
Posts: 9643
42
Android Google Web Toolkit Hibernate IntelliJ IDE Spring Java
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator

Ernest Friedman-Hill wrote:The new-post icons ...; with UBB, they were computed with Javascript inside your browser.... The old client-side ones were often wrong, ...



+1
 
Ranch Hand
Posts: 188
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
This new forum software is really nice. Hats off to you guys, I know it must have taken lots of work. Kudos!

--James
 
Ranch Hand
Posts: 42
Eclipse IDE Spring Java
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Nice work Jeanne
 
Ranch Hand
Posts: 580
Eclipse IDE
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hey guys, I had few BOOKMARKS in my profile.... There was no problem when there was change in site.From yesterday all my bookmarks are missing... Will you guys please look into this issue.

Thankyou.
 
James Tharakan
Ranch Hand
Posts: 580
Eclipse IDE
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator

James Tharakan wrote:Hey guys, I had few BOOKMARKS in my profile.... There was no problem when there was change in site.From yesterday all my bookmarks are missing... Will you guys please look into this issue.

Thankyou.


 
Ernest Friedman-Hill
author and iconoclast
Posts: 24203
43
Mac OS X Eclipse IDE Chrome
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator

James Tharakan wrote:

James Tharakan wrote:Hey guys, I had few BOOKMARKS in my profile.... There was no problem when there was change in site.From yesterday all my bookmarks are missing... Will you guys please look into this issue.

Thankyou.




Sorry no one replied over the weekend. We looked into the issue and the good news is that your bookmarks (along with everyone else's) are safe, they're just not being displayed properly. They will reappear soon!
 
Rancher
Posts: 43011
76
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator

James Tharakan wrote:I had few BOOKMARKS in my profile.... There was no problem when there was change in site.From yesterday all my bookmarks are missing...


The bookmarks should now once again be visible.
 
James Tharakan
Ranch Hand
Posts: 580
Eclipse IDE
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator

Ulf Dittmer wrote:
The bookmarks should now once again be visible.


Yes it is...
 
Ankit Garg
Sheriff
Posts: 9643
42
Android Google Web Toolkit Hibernate IntelliJ IDE Spring Java
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
There seems to be some problem when you quote someone who has written some code. This can be seen here...
 
Ernest Friedman-Hill
author and iconoclast
Posts: 24203
43
Mac OS X Eclipse IDE Chrome
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator

Ankit Garg wrote:There seems to be some problem when you quote someone who has written some code. This can be seen here...



Yep, we know about that one. Jeanne tells me she's fixed it already, and the fix will be in our next production rollout.
 
Ankit Garg
Sheriff
Posts: 9643
42
Android Google Web Toolkit Hibernate IntelliJ IDE Spring Java
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator

Ernest Friedman-Hill wrote:

Ankit Garg wrote:There seems to be some problem when you quote someone who has written some code. This can be seen here...



Yep, we know about that one. Jeanne tells me she's fixed it already, and the fix will be in our next production rollout.



Great . Someone pointed out correctly that the problem doesn't come when you quote someone. But when you edit your post which contains some code but its great to hear that it is fixed. I'm waiting for the next rollout
 
Jeanne Boyarsky
author & internet detective
Posts: 39435
768
Eclipse IDE VI Editor Java
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator

Ankit Garg wrote:I'm waiting for the next rollout


It's there now.
 
What a show! What atmosphere! What fun! What a tiny ad!
Java file APIs (DOC, XLS, PDF, and many more)
https://products.aspose.com/total/java
  • Post Reply Bookmark Topic Watch Topic
  • New Topic
Boost this thread!