• Post Reply Bookmark Topic Watch Topic
  • New Topic
programming forums Java Mobile Certification Databases Caching Books Engineering Micro Controllers OS Languages Paradigms IDEs Build Tools Frameworks Application Servers Open Source This Site Careers Other all forums
this forum made possible by our volunteer staff, including ...
Marshals:
  • Campbell Ritchie
  • Liutauras Vilda
  • Jeanne Boyarsky
  • Devaka Cooray
  • Paul Clapham
Sheriffs:
  • Tim Cooke
  • Knute Snortum
  • Bear Bibeault
Saloon Keepers:
  • Ron McLeod
  • Tim Moores
  • Stephan van Hulst
  • Piet Souris
  • Ganesh Patekar
Bartenders:
  • Frits Walraven
  • Carey Brown
  • Tim Holloway

NoSuchMethodError - NodeTest.execute()

 
Greenhorn
Posts: 6
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
I've installed the apache xalan package and I cannot get even the simplest sample to run. Sigh.
My classpath is: c:\winnit\java\classes;.;c:\winnt\java\classes\xerces.java;c;\winnt\java\classes.xalan.jar
The xerces.jar *is* from the xalan distribution.
I have run the 'EnvironmentCheck' app. Its output indicates a couple of possible problems but I cannot decode them:
ERROR: version.DOM.draftlevel=2.0unknown
ERROR: version.JAXP=1.0.1
Everything else looks OK in the output of EnvironmentCheck app.
I've done a fair bit of XML-based programming before but only using SAX2. I'm trying to learn XSLT stuff now but I'm stuck trying to set up my environment.
Any assistance would be appreciated.
 
Author and all-around good cowpoke
Posts: 13078
6
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
If your JVM is finding JAXP 1.0, you are in trouble because that is an earlier version and incompatible with the latest Xalan. You must have a JAXP.jar and probably a parser.jar file hanging around where the JVM finds it. Probably in your jre\lib or jre\lib\ext directory.
Read the findingclasses.html file in your docs\tooldocs directory to understand how such a file could be found before the file you name on your CLASSPATH.
Bill
(I wasted days chasing this down a while back)

------------------
author of:
 
Kevin Newsom
Greenhorn
Posts: 6
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
I've cleaned things up a little. Now I'm getting a different ClassNotFound error message. This one involves org.apache.xerces.parser.SAXParser. However, this class exists! It is rooted correctly with regard to my class path. And my other SAX2 applications work. It would appear that the Xalan packages are looking for the SAX2 packages and not finding them (even though they are there). What a mess. Do have any further suggestions?
Thanks.
 
Don't get me started about those stupid light bulbs.
  • Post Reply Bookmark Topic Watch Topic
  • New Topic
Boost this thread!