• Post Reply Bookmark Topic Watch Topic
  • New Topic
programming forums Java Mobile Certification Databases Caching Books Engineering Micro Controllers OS Languages Paradigms IDEs Build Tools Frameworks Application Servers Open Source This Site Careers Other all forums
this forum made possible by our volunteer staff, including ...
Marshals:
  • Campbell Ritchie
  • Liutauras Vilda
  • Jeanne Boyarsky
  • Devaka Cooray
  • Paul Clapham
Sheriffs:
  • Tim Cooke
  • Knute Snortum
  • Bear Bibeault
Saloon Keepers:
  • Ron McLeod
  • Tim Moores
  • Stephan van Hulst
  • Piet Souris
  • Ganesh Patekar
Bartenders:
  • Frits Walraven
  • Carey Brown
  • Tim Holloway

strange things with msxml & Opera5.12 & Netscape 6.1

 
Greenhorn
Posts: 4
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
i compile an html file with xml & xsl via the transfer.node method with msxml
it works fine with older netscapes and alle the IEs but when it comes to Opera and NS 6.1 the Source Code looks fine in Opera but the Source in NS and the rendered html code in both looks like this:
opera
???4???7???�???=???
ns6
0^(4)^(7)�

this is the code BTW
set xsl = Server.CreateObject("Msxml2.DOMDocument")
xsl.async = false

xsl.Load(Server.MapPath("xsl/main.xsl"))
trnsfHTML=xml.transformNode(xsl)
Response.Write trnsfHTML
any ideas?
thx
thomas
 
Thomas Kol
Greenhorn
Posts: 4
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
ah, source code looks fine in both Opera and NS but the rest is crappy anyways
 
It is sorta covered in the JavaRanch Style Guide.
  • Post Reply Bookmark Topic Watch Topic
  • New Topic
Boost this thread!