Win a copy of The Java Performance Companion this week in the Performance forum!
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic

about saxon xslt processor

 
savita jadhav
Ranch Hand
Posts: 62
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
I ma using for xslt Instant saxon from the cd provided by xml Bible.I am having IE5.0
The problem is when I give a cmmandit gives the error that
xsl namespace is not declared as the top element.
the xslt is as follow
<!--<?xml version="1.0"?>-->
<xsl:transform version="1.0" xmlns:xsl="http://www.w3.org/1999/xsl/Transform">
<xsl:template match="Periodic-Table">
<html>
<xsl:apply-templates></xsl:apply-templates>
</html>
</xsl:template>
<xsl:template match="Atom">
<p>
<xsl:apply-templates></xsl:apply-templates>
</p>
</xsl:template>
</xsl:transform>
I am new to xslt.I am learning on my own please some body guide
me what to do in this problem
Thanks
Savita
 
Mapraputa Is
Leverager of our synergies
Sheriff
Posts: 10065
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator

For some reason, xsl:stylesheet element is used much more often then xsl:transform. Try this:
<xsl:stylesheet version="1.0" xmlns:xsl="http://www.w3.org/1999/XSL/Transform">
 
savita jadhav
Ranch Hand
Posts: 62
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hi
thanks for the reply.
But I have tried for xsl:stylesheet also
<xsl:stylesheet version="1.0" xmlns:xsl="http://www.w3.org/1999/XSL/Transform">
But still its giving the same error.
Thanks
Savita
 
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic