Win a copy of Programmer's Guide to Java SE 8 Oracle Certified Associate (OCA) this week in the OCAJP forum!
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic

NoClassFound: org/jboss/naming/Util using jboss-3.0.4 and tomcat-4.1.12

 
Sanmath Shetty
Greenhorn
Posts: 4
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hi Folks,
I am using jboss-3.0.4 with tomcat-4.1.12. I have an ear file which has an MDB in it. I pass the suppporting files.. but when I try to start the server.. I get :
23:56:28,997 INFO [RMIAdaptorService] Starting
23:56:29,028 ERROR [URLDeploymentScanner] Failed to deploy: org.jboss.deployment.scanner.URLDeploymentScanner$DeployedURL@9b1b9
79f{ url=file:/C:/JBoss/jboss-3.0.4/server/default/deploy/jmx-rmi-adaptor.sar/, deployedLastModified=0 }
org.jboss.deployment.DeploymentException: Could not create deployment: file:/C:/JBoss/jboss-3.0.4/server/default/deploy/jmx-rmi
-adaptor.sar/; - nested throwable: (java.lang.NoClassDefFoundError: org/jboss/naming/Util)
Can Anybody tell me as to what to problem?
Thanx in advance
Sunny
 
Sanmath Shetty
Greenhorn
Posts: 4
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hi Folks,
For ppl who have faced the same problem or are trying to answer the same... i have got the solution.
Soln: Just make sure that your CLASSPATH is properly specified. I had messed up with the classpath actually. Apart from the classpath provided in the run.bat, only specify your set of necessary jar(the system jars need not be specified.. and also there are some client jar files which shud only be provided when you server asks for it.. in the form of Class Not Found)
Take care.
Sunny
 
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic