Win a copy of The Java Performance Companion this week in the Performance forum!
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic

Escaping > and &lt: tags in XSL

 
Kalyana Chakravarthi Kesanupalli
Greenhorn
Posts: 2
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
How to escape > and < in XSL. The browser is displaying the HTML tags as is. I have some HTML tags with content in the variable like <STRONG>test</STRONG>. I want the word "test" to come in bold in the browser. Rather I am getting the eitire text <STRONG>test</STRONG> as is.

I tried with
<xsl:value-of select="$strTest" disable-output-escaping="yes" />.

Still it does not work.

Please help me out in this.
kesanupalli@yahoo.com
Thanks in Advance....
 
Madhav Lakkapragada
Ranch Hand
Posts: 5040
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
I assume that <STRONG> is a HTML element that is already defined either by
HTML (its been a while I did any HTML work) or using CSS. That said,

You could do it this way is XSL:



If you have already tried this and it didn't work, let us know.
I have previously did similar escapes and it always worked for my.
Thanks.
[ October 06, 2004: Message edited by: Madhav Lakkapragada ]
 
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic