• Post Reply Bookmark Topic Watch Topic
  • New Topic

Troubles when using my own XMLFilterImpl sub class  RSS feed

 
Ranch Hand
Posts: 584
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hy guys,

I've been trying to solve this problem for the last two day but I am really unable to.

The problem is :

In my servlet code I create a xml filter which is a custom implementation of the XMLFilterImpl class.

Inside servlet I also create a InputStreamReader which is put as a request
attribute.

After that, I put such filter as a request attribute and then forward the request to a jsp which uses both the filter and the InputStreamReader in a x:parser call.

When seeing the results, it seems my filter is not filtering anything. However, when debugging my filter code, it seems both startElement and endElement callback methods does everything fine.

Can you please give me some light on this ? I'm not sure but do I have to create a XMLReader and associate with my filter ?



Please help me out !
[ March 12, 2007: Message edited by: Edisandro Bessa ]
 
Sheriff
Posts: 22959
43
Eclipse IDE Firefox Browser MySQL Database
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Have you got your filter working in a simple configuration, like for example a small Java application? If not, I would get it working there first. Trying to deal with JSTL at the same time only complicates things.
 
  • Post Reply Bookmark Topic Watch Topic
  • New Topic
Boost this thread!