• Post Reply Bookmark Topic Watch Topic
  • New Topic
programming forums Java Mobile Certification Databases Caching Books Engineering Micro Controllers OS Languages Paradigms IDEs Build Tools Frameworks Application Servers Open Source This Site Careers Other Pie Elite all forums
this forum made possible by our volunteer staff, including ...
Marshals:
  • Campbell Ritchie
  • Paul Clapham
  • Ron McLeod
  • Jeanne Boyarsky
  • Tim Cooke
Sheriffs:
  • Liutauras Vilda
  • paul wheaton
  • Henry Wong
Saloon Keepers:
  • Tim Moores
  • Tim Holloway
  • Stephan van Hulst
  • Carey Brown
  • Frits Walraven
Bartenders:
  • Piet Souris
  • Himai Minh

NT Domain authentication via JAAS & Tomcat

 
Greenhorn
Posts: 12
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
I implemented the NTLoginModule via JAAS at tomcat, the information I require for authentication is username biding with domain,and password. For instance, on the logon.jsp page, the user will input
User name: "myDomain\myUsername"
Password: "myPassword"

In my cases, I meet 3 scenarios as following:

1)Logon with correct domain,username,password, PASSED
2)Logon with wrong domain, correct username, password, FAILED,
but if I logon again with correct domain,username,password, FAILED
3)Other combination, FAILED,but if logon again with the correct
credentials, PASSED.

I check all log files,and can't figure out why #2 is happen, that is,
once I logoned with a wrong domain and correct username/password,
it will fail on the subsequent logon trials.

Anybody meet the similar scenario before? Any hints are
highly appreciated.

Patrick
 
A wop bop a lu bop a womp bam boom! Tiny ad:
Free, earth friendly heat - from the CodeRanch trailboss
https://www.kickstarter.com/projects/paulwheaton/free-heat
reply
    Bookmark Topic Watch Topic
  • New Topic