• Post Reply Bookmark Topic Watch Topic
  • New Topic

Websphere xml parser

 
Carrie Prebble
Greenhorn
Posts: 3
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hi,
We've recently started using Websphere 5.1 for developing our web application. We had been previously using the xerces v2.1 parser and discovered that Websphere uses the xerces v2.01 parser. One of my questions is: is it possible to upgrade the parser that Websphere uses? I read Barry Searle's "Avoiding ClassCastExceptions due to Xerces Libraries within Web Modules on Websphere Application Server" and implemented his suggestions for using a different xerces version. There was a ClassCastException for the logging service so this issue is still not solved for me. I have many questions regarding the way Websphere works and how best to use it so it doesn't get in my way of creating our application. Would the Kushner book answer these and other questions for me?
Thanks, Carrie
 
Vinod Bijlani
Ranch Hand
Posts: 133
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
i have faced the same problem. there is efix to solve this problem
http://www-1.ibm.com/support/docview.wss?rs=860&context=SW600&q1=xml+parser&uid=swg24005574&loc=en_US&cs=utf-8&lang=en+en
 
Vijay S. Rathore
Ranch Hand
Posts: 449
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Just a suggestion, update your last updated date on geocities resume.
If mentioning the version of Software and Specs., be careful to update them wrt the update time.
[ February 03, 2004: Message edited by: Vijay Rathore ]
 
Carrie Prebble
Greenhorn
Posts: 3
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Vinod,
Thank you for your quick reply. Question about your link to PQ75253, it applies to Websphere v5.0.1, is it relevant for v5.1? Could you comment on PQ77263. Searle mentions it at the bottom of his article. Is it a similar fix? Is it applicable to Websphere v5.1?
Thanks in advance, Carrie
 
Vinod Bijlani
Ranch Hand
Posts: 133
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Carrie
I don't see PQ77263 being applied in V5.0.2 or v5.1 from the release notes.
http://publib.boulder.ibm.com/infocenter/ws51help/index.jsp?topic=/com.ibm.websphere.nd.doc/info/ae/relnotes/relnotes_ae.html
makes me believe that you would need this efix but you should consult ibm support before applying.

Thanks Vijay. point taken
[ February 04, 2004: Message edited by: Vinod Bijlani ]
 
Vinod Bijlani
Ranch Hand
Posts: 133
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Carrie FYI you would get better responses with any websphere related information in websphere forum
 
my overalls have superpowers - they repel people who think fashion is important. Tiny ad:
the new thread boost feature brings a LOT of attention to your favorite threads
https://coderanch.com/t/674455/Thread-Boost-feature
  • Post Reply Bookmark Topic Watch Topic
  • New Topic
Boost this thread!