Win a copy of The Little Book of Impediments (e-book only) this week in the Agile and Other Processes forum!
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic

Have Problem in Running XML file with XSL

 
Veena Pointi
Ranch Hand
Posts: 442
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
This is my Inventory.xml file

This is my Inventory.xsl file

Whenever I run the Inventory.xml file in the browser notepad of the file is opened.Browser doesn't execute the xml file.I use Internet Explorer 6.0 version.Can I know what is the problem?
Thanks
Veena
 
Hari Vignesh Padmanaban
Ranch Hand
Posts: 578
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
HiVeena,
This is why the problem happens
i am sure this is how you wrote your xml file !!
1. opened notepad
2. wrote in all the definitions
3. saved teh file !!!
The problem is in step 3 !
when u save teh file as Inventory.xml by typing the name with the extension, Iguess notepad saves it as "Inventory.xml.txt" . Sometimes it is not shown with the .txt extension but only as Inventory.xml.
So when you try to open teh file, Explorer thinks that you want to open a .txt file and calles notepad!!
you can prevent this by doing two things
1. When u save the xml file for the first time by typing the file name in the save window, type it as "Inventory.xml" --- Type it with Quotes
---------------- or if u have already written teh file
2. you can select the file taht you had written, right click on it and rename it as "Inventory.xml"
hope this helps!!!
[ March 29, 2004: Message edited by: Hari Vignesh Padmanaban ]
 
Hari Vignesh Padmanaban
Ranch Hand
Posts: 578
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hi veena,
also there is a small mistake in the code snippet below !!

you have misspelled match as mstch !!!
if you change it, the xsl sheet works perfectly
Good luck !!

[ March 29, 2004: Message edited by: Hari Vignesh Padmanaban ]
[ March 29, 2004: Message edited by: Hari Vignesh Padmanaban ]
 
Veena Pointi
Ranch Hand
Posts: 442
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Thank you .I did rename file.But still browser opens notepad.Is there anything I should change in Internet Explorer browser settings?
Veena
[ March 29, 2004: Message edited by: Veena Point ]
 
Hari Vignesh Padmanaban
Ranch Hand
Posts: 578
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
hmm..thats interesting ...and confusing
you can try downloading a different browser (Mozilla, netscape) and see if it works in them ..
Or you might have set the default editor for xml as Notepad!!!.
Right click on your xml file, select "open with" and then say you want to choose from the list of programs.
from the list of programs that pops up , choose internet explorer !!
let me know if this works or not !!!
 
Veena Pointi
Ranch Hand
Posts: 442
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Yeah,it did work when I opened XML file with internet explorer.Thanks.But have an idea how i can fix it by opening it in internet explorer?
Thanks
Veena
 
Hari Vignesh Padmanaban
Ranch Hand
Posts: 578
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Originally posted by Veena Point:
Yeah,it did work when I opened XML file with internet explorer.


Internet Explorer
I guess that you meant some other browser :roll:

Anyway, i stick on with my opinion that it is the way the editor for teh xml fiel is configured. It has to be set to be opened with something otehr than notepad.
You can also open windows explorer and follow the menu options given below
tools ->folder options->file types and try to change the editor for xml to Internet Explorer
If it is mentioned here that xml is to be opened with IE, and stil opens with notepad, then it has to do with the file extension i guess !!! :roll:
I woudl also suggest you to download xmlspy2004!!!. they have a trial version and it is really cool !!!
http://www.xmlspy.com/
anyways, good luck
 
Veena Pointi
Ranch Hand
Posts: 442
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Thank you very much.That did work.I knew i have to change settings.But didn't know how.Thanks alot.
 
Hari Vignesh Padmanaban
Ranch Hand
Posts: 578
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Awsome
 
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic