• Post Reply Bookmark Topic Watch Topic
  • New Topic
programming forums Java Mobile Certification Databases Caching Books Engineering Micro Controllers OS Languages Paradigms IDEs Build Tools Frameworks Application Servers Open Source This Site Careers Other Pie Elite all forums
this forum made possible by our volunteer staff, including ...
Marshals:
  • Campbell Ritchie
  • Paul Clapham
  • Ron McLeod
  • Tim Cooke
  • Junilu Lacar
Sheriffs:
  • Rob Spoor
  • Devaka Cooray
  • Jeanne Boyarsky
Saloon Keepers:
  • Jesse Silverman
  • Stephan van Hulst
  • Tim Moores
  • Carey Brown
  • Tim Holloway
Bartenders:
  • Jj Roberts
  • Al Hobbs
  • Piet Souris

Problems with BOTH j2ee tutorial 1.4 and 1.3 ConverterApp Please Help!

 
Greenhorn
Posts: 1
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
Hi,

I am currently trying out the ConverterApp tutorial found on the java.sun website. I am running on win 2k professional and using j2sdk 1.4.2.

When I tried out the j2ee 1.4 tutorial (on the 1.4 platform) using the deploytool, the problem is that java bean could not be created and would show up on the tree (in fact, i could not create anything, not even the application client).

Then i uninstalled the j2ee 1.4 platform and installed the 1.3.1 one instead. So i tried out the j2ee 1.3 tutorial. This time, I am able to create all the JAR and WAR files that I needed (phew). However, there was a problem with the java bean, with the exception that the class loader could not be made. This lead to problems with deploying the bean and here is what appeared in the log file:

java.lang.RuntimeException: Class loader could not be made
at com.sun.enterprise.deployment.ApplicationArchivist.getClassLoader(ApplicationArchivist.java:174)
at com.sun.enterprise.deployment.EjbBundleArchivist.open(EjbBundleArchivist.java:296)
at com.sun.enterprise.deployment.EjbBundleArchivist.open(EjbBundleArchivist.java:341)
at com.sun.enterprise.deployment.ApplicationArchivist.open(ApplicationArchivist.java:407)
at com.sun.enterprise.tools.deployment.backend.JarInstallerImpl.deployApplication(JarInstallerImpl.java:147)
at org.omg.stub.com.sun.enterprise.tools.deployment.backend._JarInstallerImpl_Tie._invoke(Unknown Source)
at com.sun.corba.ee.internal.corba.ServerDelegate.dispatch(ServerDelegate.java:355)
at com.sun.corba.ee.internal.iiop.ORB.process(ORB.java:255)
at com.sun.corba.ee.internal.iiop.RequestProcessor.process(RequestProcessor.java:84)
at com.sun.corba.ee.internal.orbutil.ThreadPool$PooledThread.run(ThreadPool.java:99)

I would really appreciate it if someone could help me with this problem. Thanks a lot...
 
reply
    Bookmark Topic Watch Topic
  • New Topic