Win a copy of The Little Book of Impediments (e-book only) this week in the Agile and Other Processes forum!
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic

Clarification

 
Sub swamy
Ranch Hand
Posts: 121
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
For the SCEA for Java 2, the earlier version that needs to be completed by Dec 31, 2008 - are we allowed to used EJB 2 - local EJBs and MDBs ? I do understand that this is more of an implementation requirement - but then these would find their way into sequence / class diagrams.
 
Mikalai Zaikin
Ranch Hand
Posts: 3371
12
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
I can't be 100% sure, but I saw someone who used EJB 2.0 + for old SCEA exam assignment.

Just make sure your assignment does not explicitly mention some specific version of Java EE.
 
Marcel Dullaart
Ranch Hand
Posts: 55
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
If you specify that your solution uses J2EE 1.4 it uses EJB 2.1.
See the J2EE Tutorial and the JSR-151.
The latter shows under section 2 the parts that it consists off, e.g. EJB 2.1 (JSR-153).

Cheers,
Marcel
 
Sub swamy
Ranch Hand
Posts: 121
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
My concern was that if i decide to use MDB's or local EJB's i might need to make sure that the version is > EJB 2.0.
 
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic