• Post Reply
  • Bookmark Topic Watch Topic
  • New Topic

Error messages running Advice app

 
David Swan
Ranch Hand
Posts: 33
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hi
Im just ran the advice app and it works fine, it gives back the advice but theres just extra error information displayed to the screen. Heres the error message (i only put the first couple of lines here)
C:\Dev\SCBCD\projects\advice>java -classpath .;%CLASSPATH%;AdviceAppClient.jar AdviceClient
java.io.FileNotFoundException: C:\Dev\SCBCD\projects\advice\%J2EE_HOME%\config\s
ecurity.properties (M��ritetty� polkua ei l�ydy)
at java.io.FileInputStream.open(Native Method)
at java.io.FileInputStream.<init>(FileInputStream.java:103)
at com.sun.enterprise.util.Utility.getPropertiesFromFile(Utility.java:42
)
at com.sun.enterprise.iiop.POAEJBORB.<clinit>(POAEJBORB.java:78)
at java.lang.Class.forName0(Native Method)
etc etc....
Now as i said it works and gives me the right advice but whats giving that errormessage can anyone tell me ?
Cheers
Dave
 
David Harrigan
Ranch Hand
Posts: 43
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Can you echo out your full classpath please?
echo %CLASSPATH%
and paste here?
 
David Swan
Ranch Hand
Posts: 33
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Ok heres my classpath from a dos prompt
C:\Documents and Settings\Dave>echo %classpath%
.;.;.;%CLASSPATH%;c:\jakarta-tomcat-4.1.27\common\lib\servlet.jar;%J2EE_HOME%\li
b\j2eetools.jar;%J2EE_HOME%\lib\j2ee.jar;%J2EE_HOME%\lib\ejb10deployment.jar;%J2
EE_HOME%\lib\jhall.jar;%J2EE_HOME%\lib\j2ee-ri-svc.jar;%JAVA_HOME%\lib;;c:\jakar
ta-tomcat-4.1.27\common\lib\servlet.jar;c:\j2sdkee1.3.1\lib\j2eetools.jar;c:\j2s
dkee1.3.1\lib\j2ee.jar;c:\j2sdkee1.3.1\lib\ejb10deployment.jar;c:\j2sdkee1.3.1\l
ib\jhall.jar;c:\j2sdkee1.3.1\lib\j2ee-ri-svc.jar;c:\j2sdk1.4.1_04\lib;;c:\jakart
a-tomcat-4.1.27\common\lib\servlet.jar;c:\j2sdkee1.3.1\lib\j2eetools.jar;c:\j2sd
kee1.3.1\lib\j2ee.jar;c:\j2sdkee1.3.1\lib\ejb10deployment.jar;c:\j2sdkee1.3.1\li
b\jhall.jar;c:\j2sdkee1.3.1\lib\j2ee-ri-svc.jar;c:\j2sdk1.4.1_04\lib;
 
David Harrigan
Ranch Hand
Posts: 43
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hi,
That's a mightly big classpath, just to run the AdviceClient. In addition, it seems you're hitting a Windows bug where it's not replacing the %%'s with the actual properties (until later on).
Can you strip down your CLASSPATH to the bear minimum? This is what my CLASSPATH is set as to run the AdviceClient,
echo %CLASSPATH%
,;c:\javastuff\j2ee1.3.1\lib\j2ee.jar;adviceClientJar.jar
And all appears well with that.
-=david=-
 
David Swan
Ranch Hand
Posts: 33
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
thx for the reply, ill try that next time. my classpath is quite big as i was also running tomcat and various others bits and pieces, i must clean it up
Cheers
Dave
 
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic