Win a copy of 97 Things Every Java Programmer Should Know this week in the Java in General forum!
  • Post Reply Bookmark Topic Watch Topic
  • New Topic
programming forums Java Mobile Certification Databases Caching Books Engineering Micro Controllers OS Languages Paradigms IDEs Build Tools Frameworks Application Servers Open Source This Site Careers Other all forums
this forum made possible by our volunteer staff, including ...
Marshals:
  • Campbell Ritchie
  • Paul Clapham
  • Jeanne Boyarsky
  • Junilu Lacar
  • Henry Wong
Sheriffs:
  • Ron McLeod
  • Devaka Cooray
  • Tim Cooke
Saloon Keepers:
  • Tim Moores
  • Stephan van Hulst
  • Frits Walraven
  • Tim Holloway
  • Carey Brown
Bartenders:
  • Piet Souris
  • salvin francis
  • fred rosenberger

hfejb:arghhh

 
Greenhorn
Posts: 5
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
hello,

I am new to EJB and am experiancing difficlulty getting up and running. I have installed java sdk to C:\java and J2EE to C:\j2sdkee1.3.1 and my path settings are:

ANT_HOME C:\apache-ant-1.6.2
CLASSPATH C:\j2sdkee1.3.1\lib\j2ee.jar
J2EE_HOME C:\j2sdkee1.3.1
JAVA_HOME C:\Java
PATH C:\j2sdkee1.3.1\bin;C:\java\bin;C:\apache-ant-1.6.2\bin

however when I try to execute j2ee -verbose at the command line to start the server I get the following error ... I have reinstalled everything twice and searched around without any luck... I am using windows XP.

When I do "j2ee version" i get

Java 2 Enterprise Edition version 1.3.1, build 1.3.1-b17

so it says to me that the classpath is set. If only I get get the server running I can continue with the book ... which is otherwise brilliant.

Any help greatly appreciated, this is kinda crossposted with https://coderanch.com/t/314801/EJB-JEE/java/Head-First-EJB


Logging for J2EE Server Version: 1.3.1-b17 started at: Sat Aug 28 20:36:53 BST 2004..
Using the Java HotSpot(TM) Client VM and the version number 1.5.0-beta2 from Sun Microsystems Inc..
VM is using the classpath: C:\j2sdkee1.3.1\lib\system\cloudscape.jar;C:\j2sdkee1.3.1\lib\system\tools.jar;C:\j2sdkee1.3.1\lib\cloudscape\RmiJdbc.jar;C:\j2sdkee1.3.1\lib\cloudscape\cloudclient.jar;C:\j2sdkee1.3.1\lib\classes;C:\j2sdkee1.3.1\classes;C:\j2sdkee1.3.1\lib\j2ee.jar;C:\j2sdkee1.3.1\lib\toolclasses;C:\j2sdkee1.3.1\lib\j2eetools.jar;C:\j2sdkee1.3.1\lib\locale;;C:\Java\lib\tools.jar;C:\j2sdkee1.3.1\lib\jhall.jar .
J2EE Home Directory has been set to: C:\j2sdkee1.3.1.


Exception in thread "main" java.lang.NoClassDefFoundError: com/sun/corba/se/internal/util/IdentityHashtable
at com.sun.corba.ee.internal.javax.rmi.CORBA.Util.<clinit>(Util.java:87)
at com.sun.corba.ee.internal.POA.POAImpl.activate(POAImpl.java:935)
at com.sun.corba.ee.internal.POA.POAImpl.activate_object(POAImpl.java:895)
at com.sun.corba.ee.internal.CosNaming.TransientNameService.initialize(TransientNameService.java:117)
at com.sun.corba.ee.internal.CosNaming.TransientNameService.<init>(TransientNameService.java:70)
at com.sun.enterprise.iiop.POAProtocolMgr.initializeNaming(POAProtocolMgr.java:103)
at com.sun.enterprise.server.J2EEServer.run(J2EEServer.java:226)
at com.sun.enterprise.server.J2EEServer.main(J2EEServer.java:972)

 
Ann Person
Greenhorn
Posts: 5
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Solved, dont use java 1.5 beta, reverted to 1.4 and all was fine !
 
Cowgirl and Author
Posts: 1589
5
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Thank-you for posting this Ann!

We have never tried it with beta 1.5, so I'm really glad you told us it that there's a problem and that dropping back to release 1.4 fixed it.

The biggest hurdle in the book is simply getting past that first full deployment and run. Considering there's a hundred places where it can go wrong in non-intuitive ways...

Thanks so much for posting the issue.

cheers,
Kathy
 
An elephant? An actual elephant. Into the apartment. How is the floor still here. Hold this tiny ad:
Devious Experiments for a Truly Passive Greenhouse!
https://www.kickstarter.com/projects/paulwheaton/greenhouse-1
    Bookmark Topic Watch Topic
  • New Topic