• Post Reply Bookmark Topic Watch Topic
  • New Topic
programming forums Java Mobile Certification Databases Caching Books Engineering Micro Controllers OS Languages Paradigms IDEs Build Tools Frameworks Application Servers Open Source This Site Careers Other Pie Elite all forums
this forum made possible by our volunteer staff, including ...
Marshals:
  • Campbell Ritchie
  • Paul Clapham
  • Tim Cooke
  • Jeanne Boyarsky
  • Liutauras Vilda
Sheriffs:
  • Frank Carver
  • Henry Wong
  • Ron McLeod
Saloon Keepers:
  • Tim Moores
  • Frits Walraven
  • Tim Holloway
  • Stephan van Hulst
  • Carey Brown
Bartenders:
  • Al Hobbs
  • Piet Souris
  • Himai Minh

Head First w/1.4 Certification?

 
Greenhorn
Posts: 4
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
(Please excuse me if this has been posted before)

I just started working with the Head First book, which says "use J2EE 1.3, not 1.4 because the Certification is 1.3". Well, as it turns out, Sun has since upgraded their exam to 1.4 (although the 1.3 is still there too).

Are there any plans to release an "update" to the book of some kind, or to discuss the differences between the exams that the book doesn't cover? It's a great book which I'd love to use, and I know I can still take the "old" 1.3 exam, but.......

-Shawn
 
Ranch Hand
Posts: 293
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
Shawn -
It is the Sun Certified Web Component Developer certification that has been upgraded to 1.4, not the Business Component Developer certification.

So, for SCBCD stick with 1.3.

TJ
 
Shawn Kelly
Greenhorn
Posts: 4
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
Oops... my bad. Thanks for the response!
 
Ranch Hand
Posts: 33
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
Hi,
I was wondering if any one knows when the SCBCD exam will be upgraded to include J2EE 1.4. I want to take the exam probably next year.

Thanks
vijaya
 
Cowgirl and Author
Posts: 1589
5
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
Right now we don't have a scheduled plan for updating the exam. The changes in J2EE 1.4 have *very* little affect on the SCBCD exam, so there's a possibility that we might wait until J2EE 1.5, which will have a MAJOR effect on EJB!

It's more likely that we will update the exam only in terms of the *version*, and we'd update the book as well, but that the actual QUESTIONS would not change. Because again, the EJB 2.1 spec has changed very little over of the parts that affect business components (main addition is related to Web Services, which we aren't addressing in this exam anyway).

I'll keep you posted, but I do know that nothing will happen any time soon.

cheers,
Kathy
 
Bring me the box labeled "thinking cap" ... and then read this tiny ad:
Garden Master Course kickstarter
https://coderanch.com/t/754577/Garden-Master-kickstarter
reply
    Bookmark Topic Watch Topic
  • New Topic