Win a copy of Java Challengers this week in the Java in General forum!
  • Post Reply Bookmark Topic Watch Topic
  • New Topic
programming forums Java Mobile Certification Databases Caching Books Engineering Micro Controllers OS Languages Paradigms IDEs Build Tools Frameworks Application Servers Open Source This Site Careers Other Pie Elite all forums
this forum made possible by our volunteer staff, including ...
Marshals:
  • Campbell Ritchie
  • Paul Clapham
  • Ron McLeod
  • paul wheaton
  • Devaka Cooray
Sheriffs:
  • Jeanne Boyarsky
  • Tim Cooke
  • Liutauras Vilda
Saloon Keepers:
  • Tim Moores
  • Tim Holloway
  • Stephan van Hulst
  • Carey Brown
  • Piet Souris
Bartenders:
  • salvin francis
  • Mikalai Zaikin
  • Himai Minh

(hd first SCBD) NoClassDefFoundError: /util/JDKBridge

 
Greenhorn
Posts: 3
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
Well thanks for paying attention to this post:


these are my environement variables :

JAVA_HOME : c:\j2sdk1.4.2_04
J2EE_HOME : c:\j2sdkee1.3.1
PATH : c:\j2sdk1.4.2_04\bin;c:\j2sdkee1.3.1\bin
CLASSPATH : c:\j2sdk1.4.2_04\lib\j2ee.jar;%J2EE_HOME%\lib\j2ee.jar;

This is my current directory and files inside after a dir command:

R�pertoire de C:\j2sdk1.4.2_04\bass\projects\advice

12/05/2005 02:18 <DIR> .
12/05/2005 02:18 <DIR> ..
12/05/2005 02:12 3 657 AdviceApp.ear
12/05/2005 02:13 22 313 AdviceAppClient.jar
12/05/2005 02:18 1 418 AdviceClient.class
10/05/2005 01:22 887 AdviceClient.java
11/05/2005 21:06 <DIR> classes
11/05/2005 21:06 <DIR> src

I am no longer blocked with the compilation command but now it's terrific and nobody faced this in the previous posts.

I am a bit at lost with the following error when I try to run this :

I typed : java -cp %CLASSPATH%;AdviceAppClient.jar AdviceClient

I ve got this :

Exception in thread "main" java.lang.NoClassDefFoundError: com/sun/corba/se/internal/util/JDKBridge
at com.sun.corba.ee.internal.core.IOR$LocalCodeBaseSingletonHolder.<clinit>(IOR.java:90)
at com.sun.corba.ee.internal.core.IOR.<init>(IOR.java:238)
at com.sun.corba.ee.internal.iiop.messages.LocateReplyMessage_1_2.read(LocateReplyMessage_1_2.java:137)
at com.sun.corba.ee.internal.iiop.IIOPInputStream.unmarshalHeader(IIOPInputStream.java:126)
at com.sun.corba.ee.internal.iiop.IIOPConnection.getResponse(IIOPConnection.java:671)
at com.sun.corba.ee.internal.iiop.IIOPConnection.send(IIOPConnection.java:778)
at com.sun.corba.ee.internal.corba.InitialNamingClient.locateObject(InitialNamingClient.java:786)
at com.sun.corba.ee.internal.corba.InitialNamingClient.getIORUsingHostInfo(InitialNamingClient.java:597)
at com.sun.corba.ee.internal.corba.InitialNamingClient.resolveCorbaloc(InitialNamingClient.java:573)
at com.sun.corba.ee.internal.corba.InitialNamingClient.resolveUsingORBInitRef(InitialNamingClient.java:544)
at com.sun.corba.ee.internal.corba.InitialNamingClient.cachedInitialReferences(InitialNamingClient.java:1080)
at com.sun.corba.ee.internal.corba.InitialNamingClient.resolve_initial_references(InitialNamingClient.java:981)
at com.sun.corba.ee.internal.corba.ORB.resolve_initial_references(ORB.java:2425)
at com.sun.enterprise.naming.SerialContext.getProvider(SerialContext.java:52)
at com.sun.enterprise.naming.SerialContext.lookup(SerialContext.java:120)
at javax.naming.InitialContext.lookup(Unknown Source)
at AdviceClient.go(AdviceClient.java:20)
at AdviceClient.main(AdviceClient.java:12)

Please tell me where I have been wrong, because for sure I am wrong somewhere...
--------------------------------------------------------------------------------
 
Author & Gold Digger
Posts: 7617
6
IntelliJ IDE Java
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
This is a well-known issue. Please have a look at http://wickedlysmart.com/HeadFirst/HeadFirstEJB/HeadFirstEJBNotes.html
 
Greenhorn
Posts: 2
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
I had the same problem.

I've followed the steps described in the wickedly smart website and I still got the same error

Any ideas?

Thanks!!!
 
Leonardo Borges Barbosa
Greenhorn
Posts: 2
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
I've discovered my problem.

I am using Eclipse to complie my client. But my IDE was set up to use the JRE1.5 to run.... that was the problem. I changed to JRE1.4 and worked fine!

Thanks!!!
 
She said she got a brazillian. I think owning people is wrong. That is how I learned ... tiny ad:
Thread Boost feature
https://coderanch.com/t/674455/Thread-Boost-feature
reply
    Bookmark Topic Watch Topic
  • New Topic