Win a copy of Functional Reactive Programming this week in the Other Languages forum!
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic

Could not connect to localhost

 
Agasthya Iyer
Greenhorn
Posts: 17
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Dear Folks,

When I try to start the deploytool, I get a message in the command prompt "Could not connect to localhost". Becuase of that in the deploytool screen I could not see the Servers listed. I was able to verify the bean and when I wanted to deploy I get the message "Please connect to a server before deploying AdviceApp". The OS I am using is Windows 2000. I am using j2sdkee1.3.1 and j2sdk1.4.2_06.

Any help would be greatly appreciated.

Thanks and Regards,
Agasthya
 
Agasthya Iyer
Greenhorn
Posts: 17
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Sorry. My bad. Please ignore my previous email. I realized that my RI server was shut down for some reason. Now when I try to run the AdviceClient I get the following error:


C:\scbcd\projects\advice>java -cp %CLASSPATH%;c:\scbcd\projects\advice\AdviceApp
Client.jar AdviceClient
java.rmi.RemoteException: CORBA BAD_OPERATION 0 No; nested exception is:
org.omg.CORBA.BAD_OPERATION: minor code: 0 completed: No
org.omg.CORBA.BAD_OPERATION: minor code: 0 completed: No
at java.lang.Class.newInstance0(Native Method)
at java.lang.Class.newInstance(Unknown Source)
at com.sun.corba.ee.internal.iiop.messages.ReplyMessage_1_2.getSystemExc
eption(ReplyMessage_1_2.java:93)
at com.sun.corba.ee.internal.iiop.ClientResponseImpl.getSystemException(
ClientResponseImpl.java:108)
at com.sun.corba.ee.internal.POA.GenericPOAClientSC.invoke(GenericPOACli
entSC.java:132)
at org.omg.CORBA.portable.ObjectImpl._invoke(Unknown Source)
at headfirst._Advice_Stub.getAdvice(Unknown Source)
at AdviceClient.go(AdviceClient.java:26)
at AdviceClient.main(AdviceClient.java:11)

Any help would be appreciated.

Thanks,
Agasthya Iyer
 
Valentin Crettaz
Gold Digger
Sheriff
Posts: 7610
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
This should get you started
 
Veena Pointi
Ranch Hand
Posts: 442
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
I think this is related with methodName having same name Advice as interface.Try changing method Name .The above link explains in detail.
 
Darya Akbari
Ranch Hand
Posts: 1855
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hi,

try to simply restart RI first, at least it worked for me

Regards,
Darya
 
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic