Win a copy of The Little Book of Impediments (e-book only) this week in the Agile and Other Processes forum!
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic

need help

 
Dinuka Arsakularatne
Ranch Hand
Posts: 198
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
hi guys,

i just passed scwcd some days back. want to get along with scbcd 1.3. but i see that scbcd 5.0 is going to be available. but as i do not have any prior knowledge in ejb's do you recommend that i read the head first book which is on ejb 2.0 and then prepare for the new ejb 3.0?
and what do i need to set up and run ejb code? any IDE that i could use?

thank you in advance.
 
Dinuka Arsakularatne
Ranch Hand
Posts: 198
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
and also what changes do i need to make to my CLASSPATH variables? i am using netbeans 5.0 already. could i use this to preare for the examination?
 
Rajan Murugan
Ranch Hand
Posts: 182
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Originally posted by Dinuka Arseculeratne:
and also what changes do i need to make to my CLASSPATH variables? i am using netbeans 5.0 already. could i use this to preare for the examination?


at this stage do not use any ide.since you are fresh to EJB.

Since you are starting go through books focused at EJB 3.0 directly.You do not have time(in case you want to first do EJB 2.0 and then EJB 3.0 it will be a good learning curve). You can read the first 2 chapters to get to know and understand what EJB is and how it is different from RMI.

At this stage you do not have any book focussed at SCBCD 5.0 (I wonder how anyone can prepare a book when the official syllabus is itself not yet finalized)

You have Mastering EJB 3.0 in PDF and in print format (pdf is freely available)

there is one more book by orielly.

If you have already referred any of there books you know what to expect depending upon your liking choose either or both.

There are few more available on EJB 3.0.

I am not aware of the content and the type of content.

You need a server that supports EJB 3.0
You need the lib files in case you havec a server which does not have the necessary files.
 
Dinuka Arsakularatne
Ranch Hand
Posts: 198
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
where can i find the free pdf of mastering ejb 3.0? so you are suggesting not to read hfsj as ejb 2.0 is outdates is it? will mastering ejb3.0 start from the basics? because i am totally new to ejb's.

and lastly what are the servers that support ejb's?

thank you
 
Rajan Murugan
Ranch Hand
Posts: 182
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Originally posted by Dinuka Arseculeratne:
where can i find the free pdf of mastering ejb 3.0? so you are suggesting not to read hfsj as ejb 2.0 is outdates is it? will mastering ejb3.0 start from the basics? because i am totally new to ejb's.

and lastly what are the servers that support ejb's?

thank you


Need to know EJB 2.0 will be there as long as there are apps out there that need to be maintained.So if your need is to work on EJB you can start with EJB 2.0 and for that HFEJB is good start.

check out this website www.theserverside.com for mastering ejb (new and past editions).
Download and check for yourself whether you are comfortable with it.
 
Rajan Murugan
Ranch Hand
Posts: 182
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
I asked you to focus on EJB 3.0 since you asked about scbcd 5.0
 
Dilshan Edirisuriya
Ranch Hand
Posts: 299
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
I'm also having the same problem. Is it okay if I read the HFEJB and then attempt to learn EJB 3.0
 
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic